Accidentally update to 5.3 and now can't jailbreak, please help

I accidentally updated to 5.3 from my 4.4.4 and now I can’t jailbreak my Apple TV 2. How can I undo this, please help. I just bought the device and didn’t save anything before

Looks like we have the same problem. I need to know how to downgrade if possible.

if the blobs weren’t save you are stuck on 5.3 until another jailbreak becomses available. if one becomes available at all

Same here. Just given a mates ATV2 and the first thing I did was update firmware, then patch.


NO WHERE did any instrcutions suggest we do things like save this BLOB thing (whatever that is).

Very frustrating. I wish the seasonpass was smart enough to ask us this, in the first place. At least do a version check of the current firmware and ask us if we want to back that up.

I’ve firmware updateed bucket loads of modems, routers, motherboards, etc… and never had i heard before that these blobs (I’m assuming a blog == the firmwear for an Apple TV) are device specifc that’s crazy talk!

What happens if i have -another- ATV2 in the house that hasn’t been touched in ages? can i grab the firmware on that and move it over to my 5.3 to downgrade?

this is crazy…

I agree it didn’t say to backup the blobs. Disappointed, I convinced someone to swap me an old ATV2 and I brought him a new ATV3.


Being an andriod fan I am feeling shamed that I brought an apple product for one reason, to jailbreak and run xbmc and now I can’t do that, for now. So annoying.

Sorry to hear about your troubles, I too wish they had put a warning in sooner, but it seems the next version of seasonpass will have that warning, see for the confirmation and discussion.


p.s. the whole thread is an interesting read (even though I and another guy got a beating for being noobs by suggesting some sort of warning.)

no matter what firmware you are on or whether you have an shsh blob or not you can always do the 4.4.2 tethered jailbreak indicated here

Has anyone tried this? Does it work?

lol have you read the thread? The thread wouldn’t be 20 pages long if it didn’t work. But to answer you question it does work. I personally got it to work on several ATV 2

Will give it a go.


Thanks :wink:


are there any firmware’s at all that are untethered when we don’t have any blob’s, etc? 4.4.2 you said has to be thethered. even if it means going back to the earlier releases?

No - 4.4.2 tethered is the only release that anyone who does not have blobs has been able to install.   I am not sure why even that one works without blobs.

I got the Same problem as well guys.
Very frustrating. I used ifaith with all the blobbs fixes and went through iTunes.
Turned on the apple tv 2 and I saw that I got the 5.3.

Same boat here but i’m wondering why someone can’t simply upload their blob that is for something we could downgrade to?  is it the 5.3 firmware that is preventing that?  feel free to make fun of the question - just answer it while you do please.

on that note: If i had a friends ATV2 could i save that blob and install into my ATV2 running 5.3?

The blobs are specific to your device. 

Can anyone confirm success since since the introduction of 5.3?  

The current release is irrelevant, but you need to use the method in this link…

Thanks, Sufferinsuccotash.  Is this process still for Windows only?  If so, is there any solution for MAC users?

I’m assuming since iFaith is needed for this process you will need a PC for it to work.  But I’m not a MAC user and I haven’t read through the 20 pages of posts in that thread so I’m not certain.  Can’t you just run windows on your MAC?

I read through all 20 pages and it seems like there is still no MAC solution.  Everything I read says that MAC users can only hope to save their blobs through Tiny Umbrella and will have to wait for a signed version – perhaps in the future.  Nowhere do I see a MAC-for-windows solution mentioned as an alternative which I assume I would – if one existed.