AC3 Passthrough for DD 5.1

Hi Guys,

Have been looking all over the forum at posts complaining about the fact that AC3 passthrough support seems to be broken, so I have a few questions:

  1. Is this related to a specific version of ATV (i.e. 2.3)?

  2. When will this get fixed? and is it something we have to wait for from Apple directly, or is it just an ATV Flash 2.3 support issue?

Kind Regards,
Paul.

AC3 pass-through is actually working. The only difference is with the 2.3 Apple TV software, Apple is actually ENFORCING their dual audio track requirement. In the past they have stated all media should have dual audio tracks (primary AAC, secondary AC3). If your movies are encoded this way, AC3 will work. However, in previous version movies with only an AC3 track played just fine.

Trying to find a way around it, but it’s not looking very promising.

Has anybody else identified the problem whereby after playing a file with DD5.1 encoding, that regular stereo files (such as podcasts and iTunes music) fail to play - ie the file plays, but no audio is heard?

This is the problem I experience, and the only remedy seems to be reflashing the AppleTV after watching something with a 5.1 audio track.

In the meantime, what I did is gone back to ATV firmware 2.1.
This firmware works fine with the 3.4.5 atvflash.
Might work too with the new 3.5 version. I will try it tonight.

Ok, for those of you who don’t know you need an 2 channel track with an AC3 track. The apple tv will not recognize the audio tracks unless you do. So simply open handbrake import your movie or dvd select audio make the first track AC3 Passthrough and the second track an AAC 2 channels stereo track. Now this works on ever apple tv version that i have tried and i have 3.4 currently here is a screen shot. I forgot to add even though it says dolby pro logic it is true dolby digital if your converter has an indicator it should appear once the movie starts and make sure you enable ac3 in every possible option on apple tv

A little silver lining to go along with the hassle of a maintenance update.

2.3.1 has fixed the AC3 passthrough issues that appeared in 2.3. It seems to be working as it has in previous versions (pre 2.3). That is, videos with only a single AC3 audio track will now play correctly, where in 2.3 two audio tracks were required.

[attachment=0]DD.jpg[/attachment]
This should help those with movies already encoded with a single AC3 audio track.

Going forward, it may be prudent to specify two audio tracks (AAC Primary and AC3 Secondary) when encoding new movies, just in case this issue ever appears again.

you stole my screenshot? j/k. guys follow my simple instructions on my last post…same goes for DTS files to if your stereo can decode DTS that is. Use XBMC to play these or else it might stutter and lag XBMC doesn’t have a problem with high quality bit rates either ;)…Oh and Mr. ATV Flash I still required to have that extra AAC track. with version 2.3.1. XBMC works with only the AC3…nito tv and sapphire and others still need the AAC track. I will mess around with it some more and see if I have something turned off. Oh and you most likely want the AC3 track first some of the apps let you choose others choose the first known track. But i’ve seen it both ways…

Make sure you have the AC3 passthrough set to ‘on’ whether in Files > Settings or Media > Sapphire > Settings.

It already is on…but 2.3.1 was suppose to fix the ac3 passthrough…seems as though it hasn’t for me still requiring both tracks

AC3 with a single file still doesn’t work for me either w/ the new update. Any ideas?

Use both tracks… AAC + AC3