A few questions.. blobs.. updating to the latest iOS

I bought an ATVg2 that had 4.4.4 on it and I followed various instructions across the web trying to jailbreak it with that version- nothing worked right (used TOTALCOMMANDER and all these other pulleys, mirrors and trap doors but got a error 16-something in iTunes)- so I ended up going to the ATV 5.0 software and using Seasonpass for a tethered jailbreak. I installed XBMC and so far as happy as I could be.

What’s in question is if my saved SHSH files are any good- this is what I have- ‘00000256E104F576_Apple_TV_2-4.4.4_(9A406a)-blobs.ifaith’

Is this going to work with Seasonpass or do I need to use ifaith and whatever works with that to restore an older firmware?
Can I update to 5.0.1 without losing my XBMC install? I’m 90% certain it does a clean firmware install then I get to jailbreak again, reinstall XBMC ect. Not something I’m willing to do until a few more iOS updates…

Thanks in advance!

had the same problem and it ended up my SHSH files that I save was no good, just open your SHSH files with notepad and check at the bottom the apticket line, mine was all 00000000 and that not good.For a reason couldnt save a good shsh and couldnt get it to work, always had some 1600 errors no matter what.

Yup, all 0000s in apticket. So basically I got screwed over regarding reverting back. Oh well. I don’t want to revert to an older iOS, just want to go with the newer ones anyway. I couldn’t get past the 1600 error either. I never believed the guys who said “try a different computer, try a different cable”… I did anyway and same result… the SHSH blobs were corrupt the whole time that were used to build the firmware. I’m loving having the new interface though, which I dreaded at first. It’s actually pretty nice.

Does anyone know if the untethered 5.1.1 release will wipe my ATV and I’ll have to reinstall XBMC? Not a big deal but curious. I can’t imagine an “upgrade”, I’m assuming it restores a hacked firmware through iTunes.

You cannot update the software on a jailbroken Apple TV or any iDevice for that matter using the Apple update method. You need to reflash the software which inturn does wipe the device.