7.1 audio output incorrect when using eARC

Hey everyone

I have an issue that appears to occur with hd audio codecs such as TrueHD or DTS-HD where the channel mixing gets messed up.

Audio from the centre channel comes from the right surround. Not sure about the other channels.

It does not happen when playing through MrMc with the same Apple TV, just Infuse. Nor does it happen when playing through my Zidoo player.

I wasn’t able to find anyone else with the issue, so any ideas?

Edit: Sample here

Audio #1
ID : 2
Format : MLP FBA 16-ch
Format/Info : Meridian Lossless Packing FBA with 16-channel presentation
Commercial name : Dolby TrueHD with Dolby Atmos
Codec ID : A_TRUEHD
Duration : 1 h 20 min
Bit rate mode : Variable
Bit rate : 2 871 kb/s
Maximum bit rate : 4 608 kb/s
Channel(s) : 8 channels
Channel layout : L R C LFE Ls Rs Lb Rb
Sampling rate : 48.0 kHz
Frame rate : 1 200.000 FPS (40 SPF)
Compression mode : Lossless
Stream size : 1.62 GiB (6%)
Title : Dolby TrueHD/Atmos Audio / 7.1+11 objects / 48 kHz / 2871 kbps / 16-bit
Language : English
Default : Yes
Forced : No
Number of dynamic objects : 11
Bed channel count : 1 channel
Bed channel configuration : LFE

Thanks

1 Like

Are you seeing this with other samples?

What type of device is your Apple TV connected to?

What is the Audio Format option set to?

I just tested your sample here with a traditional 5.1 AVR setup (tried with the Audio Format set to Auto and Dolby 5.1), and the dialogue in your sample was correctly coming out of the center channel.

Very strange.

Setup is as follows:

Apple TV 4K (2020, I believe) > Sony a90j > Onkyo rz50 (earc)

Sony eARC is set to auto
Apple audio format is set to auto, atmos available
Onkyo is set to direct, however sound is coming from the right surround in all modes but stereo.

Tested with the following apps:
Infuse - sound comes out of wrong speakers
MrMC (paid) - sound output is correct
VLC - sound output is correct

If I play the compatability track (Dolby Digital 5.1, didn’t include in the sample to save space) the sound outputs correctly in Infuse.

Using Infuse Pro 7.5.8

I just went through a few videos in my library.

it seems all DTS-HD or TrueHD 7.1 tracks are doing this. 5.1 are playing fine.

How is Infuse handling tracks differently to these other apps?

Edit: plex works fine as well, and I can confirm no transcoding of audio or video as reported by plex dash.

Some more testing. This only happens with eARC. Connected directly into the avr the sound works fine.

This suggests something wrong with how the tv (Sony A90J) outputs 7.1 LPCM, however I’m still not convinced as MrMC, VLC, and Plex haven’t got any issue.

Infuse uses the newer audio pipelines (which allow for things like spatial audio and Atmos) whereas the other apps are probably using older ones.

This may be a bug in tvOS when using eARC.

Not sure, but it looks like I’m not alone.

When did Infuse adopt this new audio pipeline?

This guy had the same issue, and he posted about it 3 months ago. A couple of commenters seemed to share it, and in my own post, one of the commenters also experiences it.

The common factors seem to be Infuse and eARC. Our TVs were different (mine is a Sony A90J, another was an LG C2, and the third a Sony X90J), our AVRs were different (Onkyo RZ50, Denon, Onkyo NR7100), but all had issues with 7.1 when going through eARC and playing with Infuse.

Is there another app you know of that uses those same audio pipelines that I can test with?

I did some more testing with a DTS-HD demo disk’s speaker assignment video. DTS-HD 5.1 was fine, DTS-HD 7.1 played like this:

Front left came from front left :slight_smile:
Center came from surround right :frowning:
Front right came from surround left :frowning:
right side was silent :expressionless:
right rear was silent :expressionless:
left side came from the sub :frowning:
left rear came from the sub :frowning:
LFE came from the sub :slight_smile:

So the issue is when three conditions are met: eARC, Infuse, 7.1. Take one out of the equation and everything is fine.

Thanks for the info. This is the first time I am seeing a report of issues here, but we can look into this to see if there’s anything we can do from the Infuse side to improve this.

1 Like

Why would you plug ATV to TV instead of receiver? Just plug it into AVR, that’s what it’s for.

Could be a lack of inputs available or maybe they wish to use the Apple TV with just the TV speakers at times instead of the receiver.

It could also be a CEC thing that makes things work better.

To legitimately answer your question, there could be a few reasons. For example, Sony tvs cannot do VRR AND Dolby Vision. It’s either one or the other. So, let’s say someone has a gaming console and an Apple Tv, they cannot connect both to the AVR without sacrificing one or the other.

Or perhaps they do not have an AVR compatible with DV, they need to go via earc.

Maybe they use a Bluenode or something with earc, but no hdmi in.

There are many reasons, and even if there were none, should a bug go ignored because it doesn’t affect one configuration?

Has there been any movement on this?

At the moment Infuse is only useful for playing older (5.1) files, or files from streaming.

I can’t believe eARC would be a niche use case to not warrant a quick fix.

This bug is still present, by the way.

It is clearly a bug with tvos17, though. Since first posting about it, Plex now has the same issue. MrMc doesn’t only because it hasn’t been updated in such a long time.

Would be great if Infuse could implement a workaround, but the only way I’ve found to fix it is to go into the Apple TV’s settings>Video and Audio and under Audio change the Audio Format from “Change format off” to Dolby Digital 5.1.

Hopefully you won’t notice a drop in audio quality.