6.2.2 old formerly erased favorites pop up

Hi, since the last 6.2.2 update, I have older favorites in my favorite list, that had been erased long time before.
Can I just erase them again, and hope they won’t come back?
This, Gregor

I’d give it a shot and see. Sounds like a glitch and probably will be fine to hide again.

This has just started happening to me as well. Incredibly annoying. I’ve deleted the favorites a bunch of times and they keep coming back.

Do I need to reset all my settings and start from scratch? Is there a way to clear out the list of favorites somewhere so this stops happening?

Are you still running 6.2.2 still? If your running 6.3.6 (released today) then are these favorites you created or are they the ones Infuse creates from the Library? Also do you have iCloud sync turned on?

I tried updating to the new version. No change.

I do have iCloud Sync turned on. I have a phone, and two Apple TV’s, I would like them all to have the right shares/favorites listed.

I tried clearing the metadata for all my devices, I deleted the favorites and the shares, shut down, rebooted, turned the app off, disabled Cloud Sync and then re-enabled one at a time.

Nothing has worked so far. I have iCloud Sync now disabled, and it isn’t updating. But it isn’t going to sync my watch history between the devices either, then, right?

Today I found out that I also have all previous favourites that were deleted have returned from the dead.
I removed them again. I hope this is not an ongoing thing.
I never had any deleted favourites till last month when I made changes. (Good name for a tv show “The return of the deleted dead”.)

Thanks for confirming Gramophone that it isn’t an isolated thing.

This is super frustrating. I haven’t modified these in a while, so I can’t be sure when the issue began.

Most recent experience was due to a new hard drive being purchased and the need to update the favorites SMB locations.

For the team that is reproducing this: A note that could be useful. The favorites removed and the new ones have the same name.


Family Shows
Initially: smb/HDrive/Family
Created new Family Shows
Now: smb/GDrive/Family

I’m using atv4k and latest update, and now removed Favourite folders are coming back. Usually the next day or two. They are empty as they were deleted from the hard drive also. When they come back they also have the custom artwork so they must be stored somewhere.
Is it possible some refresh is putting them back?