5.3 firmware soft-boot needs teather.

Recently Jailbroke apple tv2 5.3 teathed… jailbreak worked fine no problems, installed xmbc and nittoTV. appleTV works 100% although if the system freezes and i do a soft boot, (ie. hold back and menu until the status led on the appletv blinks) it shuts down, displays the apple icon and will not reload the main menu. apple tv then flashes again and trys to restart agian to no avail.

now in order to get past this i must do a teathered boot where everything will work fine untill the system either sleeps or i reset it through the remote…

I do understand that if i unplug the atv i will have to teather boot it, but it am getting this error even tho the atv IS PLUGGED IN the entire time.

ive tried re running the reloading ipsw. still have the same issue…

any light on the subject? 

recap : teathered boot needed w/o unplugging the power cord i have it plugged in the entire time

thanks for any help much appreciated    



I believe this is expected (albeit unwelcome) behaviour.

As I understand it, any time you do something that means the OS needs reloading then a tethered boot is needed. The commonest cause is removing power, but forcing a reboot of the OS via the remote will also lead to a tethered boot being needed again.