5.3 failed install now stuck...

Surprise, as new update comes out, I follow instructions to the letter and it doesnt work. This happens on every single update for me, I waste a day getting it fixed…

So I downloaded new Seasonpass, clicked create ipsw, connected atv to my Mac, it went inot FU mode, finished, connected it to TV, and had the connect to iTunes icon. Tried process again, and now it stops at the seasonpass install of trying to get into DFU mode, the atv wont.

 

I’m stuck now with a dead aTV2, do I go into iTunes and do a restore from there and start all again? Bored of this, happens all the time, maybe me, but I follow the instrcutions.

 

Please help asap, I dont want to waste all day again on this, and at least need it functioning as an aTV again asap

Had to delete all traces on my iMac od seasonpass, restart Mac, started form beginning with Seasonpass and worked???

quick tip for you MrMister111 if you install apptrap on your Mac it will uninstall all everything associated with what you are deleting.https://www.macupdate.com/app/mac/25323/apptrap