5.2.1 SP shows as APTV v. 5.0.2

Hi There,

Unfortunately I cannot install SP 5.3 untethered because my apple computers are too old to update to OSX 10.8 or 10.9 and there is currently a bug in the SP installer that prevents it from working with OSX 10.7.5

 

Because of this I wanted to JB with SP 5.2.1 which seemed to work - however when I go to check my APTV settings it says I am running 5.0.2.  Does this make sense?  I want to update to something newer if possible because NHL center ice doesn’t seemt work in this version.

 

Thanks in advance.

There is no SP 5.2.1 - I assume you mean ATV firmware version 5.2.1?

If you have 5.0.2 on your ATV, then you can only go to later releases (other than 5.3 which Apple is still signing) if you already have saved shsh blobs (firmware signatures) for the desired release on that specific ATV. I am guessing this is not the case?

In effect that would mean you want the 5.3 untethered jailbreak? As your Mac annot run the latest SeasonPass that supports that jailbreak your best bet might be to visit a friend with a suitable machine and jailbreak your ATV there.

Thanks very much for your response! 

 

The part that I’m confused about (and forgive me because I’m obviously very green at this) is I downloaded the latest version of SP and right clicked the create IPSW and selected 5.2.1 and then ran the jailbreak. Shouldn’t that update my apple TV version from 5.0.2?  Instead it seems to have stayed the same. 

 

Thank you again.  

Solved!

Found a work around posted by @sammybaker. As follows:

"The only workaround I could think of was to downloaded the PRIOR tethered Seas0nPass JB: 0.9.3 and start from there.

VOILA!

The older Seas0nPass 0.9.3 jailbreak went through fine.
I ran the tethered boot, which also downloaded fine.
I then installed the new just released aTV Flash. (It wouldn’t take the older one from just December.)
Through the Maintenance setting, I then ran the Untether Update."

 

Worked perfectly - 

Now I have 5.3 and managed to do it on my mac running 10.7.5.