5.2.1 (6025) Keep getting "This Apple TV is not eligible for this version"

Just got a new APTV2 from an auctin site and it’s been updated to the newest verison of 5.2.1 (6025). Can it even be JB’n or am I SOL? I assume SP will not have a new untethered version soon by any chance that can crack it?

Just wondering what my options are at this point…


The first thing I would do is use the 0.9.2 beta release of SeasonPass to save your current blobs using its (new) option for that.  However at the moment trying to jailbreak 5.2.1 seems to be failing since Apple stopped signing that release.  I would not be surprised is if there is shortly an update to SeasonPass that alows you to use the saved blobs to do the tethered jailbreak of 5.2.1.  While saving the 5.2.1 blobs it is worth checking that there are not already saved blobs for that device (in case the previous owner ever did a jailbreak).

As far as I know if you do not already have saved blobs then currently the only option is to go back to the 4.2.2 release.  For some reason it seems possible to use blobs from other devices for that specific release.

Whatever you do, do not update to the 5.3 release as there is currently no jailbreak for that release.  As one can never be sure if a jailbreak will appear for new firmware releases one should not update on the basis that a jailbreak must shortly appear.

Ok thanks I have now just downloaded the beta version of SP and have tried to save the firmware signature but I get the message: “Seasons Pass was unable to save signatures for this device”. Then tried to install the 4.2.2 release but after right clicking I don’t see that version? I even just tried to hit IPSW and pretty much get the same message. 

What’s wrong with APTV2? Can I not even do the tehthered version?


I completely disabled my security settings and was able to save the firmware…I’m on the right track.

OH NO, it now has the iTunes icon with the USB going into it? What did I do wrong here? I did the tether boot option but it won’t work…

I have the same problem. On my aTV 5.0.1 and i can’t update to 5.2

Usually my firewall has never been an issue but today it was…so maybe make sure to disable it completely. 

I decided to go with the tethered latest update and it’s working now.

Just Nito TV keeps spinnding saying Searching or Update All spinning blue ball of death? I’ve treid to Putty into it with various codes but keep getting the spinning…


you do not have the same problem as the op. your apple tv with 5.0.1 can be jailbroken untethered. just use season pass beta. if you are on an untethered version don’t really worry about 5.2 use the 5.0.1

+1 for this… turn your firewall off

It seems clear that there is now an issue with jailbreaking 5.2.1.  

I have two non-jailbroken units – a 5.2.1 and 5.2 – and wonder what I should do.  Is there any danger in trying to jailbreak and receiving these errors?  What is the status of these units once they receive errors?

Are there other firmware versions that were updatable before the release of 5.3 – and now are not?  It seems like I picked a bad time to buy non-jailbroken units and JB them for friends and family, eh?

I am new to this Apple TV business and hope the voices of some veteran jailbreakers can add some perspective to this recent event.