5.0.2 invalid k66ap error



Im having trouble jailbreaking 2 of my apple ts 2’s running v5.0.2. I have tried ifaith v1.5.8 6-8 times and when it does try to save the blobs it comes up with a INVALID RESPONSE: k66ap error. I also tried seasonpass version 0.9.2 and it says its unable to save signatures for this Apple TV.  Can someone please help?

I have the same problem with an 5.0.2 :frowning: I have managed to jailbreak other 5.0.2 units before with no issues and various other units running different versions, so I’m reasonably confident its not ‘user error’.

i just got an apple tv 2 with 5.0.2 and am having the same problem.  getting response: k66ap when trying to save the blobs with ifaith1.5.9


anyone have any suggestions?

I have had another 5.0.2 with the same problem, most 5.0.2 work without issue, but these two refuse. I’ve tried all versions of Seas0nPass and iFaith that support dumping blobs for 5.0.2 and nothing works. Is anyone able to other some advice please?

any news on the error guys

INVALID RESPONSE: k66ap error.

as i have done lots of atvs but i now have this error on one of mine when using ifaith 1.59 and 1.58 and tries seas0npass to save signatures but that wont work either…

Did any of you go up to 5.3 and try to do a tethered jailbreak??

let me know thansks as ill do that if it works as wont be lonbg for untyether now that iphone 5s is out


Something is wrong I can’t save signatures either at firmware 5.02, but neither at 4.2.1 with any v.1.5 iFaith, what i did went back to 1.4.2 and was able to save the 4.2.1 ATV shsh blobs.

I tried all 1.5 versions up to 1.5.9 several times and couldn’t do it. 

the one @ 5.02 still can’t do it cause iFaith 1.4 only saves up to 5.0 I think, so if anyone knows how to modify 1.4.2 so it can saves higher revs signatures that will fix our problem.


In the immortal words of Hall Of Fame Packer Coach Vince Lombardi: “WHAT THE HELL IS GOING ON AROUND HERE!”

I was getting k66ap error today on a 5.1.1 - a true pig it was being.  iFaith 1.5.9 just stalled at waitig for Apple TV all the way through… Validating stuff with Apple tV (on the two occasions I got that far) were too much of a feat to be accomplished.  I tried it with power lead in and not in, nothing seemed to work.  iFaith 1.5.8 produced the k66ap error (1.5.9 just hangs)…

In the end I gave it a good talking to, booted it, reset it, and left it there being ignored for an hour.

Tried it in 1.5.8 again and it dumped proper blobs.

This was the first time I have ever managed to dump after having received k66ap error, so there is always a forlorn hope.

I’d thought I resurrect this thread in the hope that one of the affected users here came up with a solution. Hope springs eternal when it comes to this issue…  

My latest – and absolutely last – adventure with a newly acquired 5.0.2 has left me with this same K66AP error.

After not being able to get past the iFaith exploitation phase on my other two failed 5.0.2’s, I was hopeful when after the 20th or 30th attempt, iFaith finally made it past this exploitation hump – only to eventually end with the message:  “An Invalid Response Was Received From The Device.”  K66AP Error.

I’m assuming this error is FATAL and means that this unjailbroken ATV 5.0.2 will never see an untethered jailbroken moment in that version.

This is crazy because I have done SO many 5.0.2 jailbreaks in the past. And why does this seem to be the ONLY 5.X version that people are stating have this issue?

Has the universe of 5.0.2’s somehow changed, or are these just software issues?

I have to objectively wonder, question, but ultimately dismiss the idea that Seasonpass, iFaith, and Tiny Umbrella ALL have current tools that don’t work well on just this ATV version.

But really… why do all these 5.0.2’s (suddenly?) seem to be an issue?

This is great news, Ian.  I really need a copy of that “talking to” you gave your ATV.  

Curious… did you first try to save the signatures with Seasonpass?  And, if so, was it a failed attempt?

i tried reseting talking to tried leaving for and hour used 1.5.8 noluck and 1/5/9 and still got the error.

i just dont understand it i have done loads but this is now the 2nd on 5.0.2 with this error its bizare.

and now i cant even go up to 5.3 as apple aint signing that anymore lol

I believe it to be caused when there is more than one firmware image stored on an Apple tV, say after a failed update.  I have managed to dump blobs succesfully after this error message just once using the method I described earlier.  I have another one today that’s retrning that same error and so far my own experimental fix hasn’t worked, but I did forget to reset it…

Such fun!

But why does this issue affect only the 5.0.2’s?  

And, more importantly… WHY ALL OF A SUDDEN?

Many of us posting here have jailbroken many, many 5.0.2’s without an issue.  Why is it such a problem now?

How could something except external software issues be causing this?


who knows why we are getting this error its so wiered but hey ho what can we do i guess its wait till hi8sn0w and winicom relese the new untether for the phones pads and pods then shortly after it will be incorperated into seas0npass however the way i understand things its gonna be for 6.1.3 and 6.1.4 and we cant get them on that anymore as apple finally stopping signing 5,3.

i also read that the other hacker posininja or everaders may do aND IOS7 jailbreak. so its either wait for that or go to 4.4.2 tethered i guess asa i cant work it out.

let me know if u do

It’s not all of a sudden Maxie.  You’ve been lucky all along and unlucky recently.  I have had a few of these over the last year.  It is always 5.0.2 though, but I put that down to as many as 70% of ATV2 I get through my door being on 5.0.2.

  i have to agree with ian this has been happening for a while.

bizrely the other day i couldnt get anything on 5.3 so assumed apple had stoped siging it now they had brougfht at 6.0.1 but after i put the 5.0.2 with the k66ap error on 4.4.2 tethered and still couldnt get faith to save a blob i thought sod it ill just try 5.3 once more and it went up to stock 5.3 so on 5.3 stock i was able to save at least 5.3 and 6.1.4 and 7.0.3b with cydia so if and when the new jailbreak comes out at least i have saved shsh now for thuis unit.


now ill put seas0npass tethered 5.3 on it and wait for the new jailbreak with saves blobs and apt tickets for this unit.

so although there is no untethere now guys this methodf appears to be a good second best better than leaving it on 4.4.2 without a blob


have fun

Don’t forget though that the 4.4.2 IPSW is the so-called universal IPSW and so I am not surprised you can’t dump a blob from it…

yes mate agrees but its all good now i have a tethered 5.3 with saved blobs waiting for the new jb


Guys although I have not tried this myself a friend told me that of you use ifAith 1.5.1 or 1.5.2 u can get faith to save a valid blob on these 5.0.2s that won’t work on 1.5.8 or 1.5.9

Let me know if anyone get this method to work and I’ll do the same of I get a 5.0.2 on the k66 error

Thanks and good luck