4K WiFi Streaming on Apple TV (Problem)

I am unable to stream 4K movies from my NAS to an AppleTV 4K over WiFi. I have tried multiple 4K files and the experience is the same; the movies take extra long to start and they stop and buffer after less than a minute of playtime. I have troubleshooted and determined WiFI is not the problem. I have a high-end AC WiFi router that delivers >45MBps to the room I am attempting to stream to. My MacBook Pro in the same room as the 4K AppleTV streams 4K files instantly and flawlessly with zero buffering using VLC Player and Quicktime player. My network monitor shows that streaming a 4K movie from my NAS does not exceed 5MBps, well below my bandwidth capacity.

Why is Infuse not able to stream 4K MKV files? These files range in size from 10GB to 60GB. It doesn’t make sense that my MacBook can stream just fine but Infuse on the AppleTV cannot.

Any suggestions?

First, what version of Infuse are you running?

Second, what protocol are you using to connect to your share? SMB, (if SMB what level, 1,2,3,Auto?), FTP, DLNA?

Third, strictly for troubleshooting, could you connect with an Ethernet cable and see if it still has buffering issues?

I’m running the latest version of Infuse Pro. I don’t know what SMB version the NAS uses. My 4K AppleTV connected via gigabit ethernet in the downstairs plays the same 4K movies flawlessly. The downstairs AppleTV isn’t connected to a 4K TV, however. It’s just 1080p. Ever since I got a 4K TV the whole experience has become very laggy and not smooth like it is on a 1080p TV. Not just Infuse, the TVos interface and all apps are laggy which is disappointing.

It still makes no sense why my MacBook can stream 4K no problem upstairs, but the AppleTV with Infuse can’t. I have a 100ft ethernet cable I’m gonna run up the stairs just for troubleshooting purposes and see what happens. I’m new to 4K and honestly from what I’ve experienced so far, I’m not blown away. I don’t see much difference from a quality 1080p source and 4K. All my 1080p content actually looks better on the new 4K TV than it did on the old 1080p TV.

So you’re running 6.1.2 version of Infuse, just to verify.

Also, if you’re getting the same file to play back with Infuse connected via Ethernet to a different TV then the issue isn’t Infuse. It sounds like somewhere in your network settings or protocol settings you’re having issues. Are both of your ATVs logged into the same Apple account? If so they should be syncing their settings but it wouldn’t hurt to check the network settings in Infuse on both.

You can also check in the Share settings in Infuse to see what version of SMB you’re using.

I assume the wifi connection is the issue. Is it 2.4 or 5 GHz ? How fast is it (how much Mbit/s?)

The WiFi is 5ghz pulling 45MBps in the room in question. The AppleTV reads signal strength as 4 out of 5 bars. I’m gonna run a cat6 cable to this room and be done with it. I’m just perplexed as to why my MacBook Pro in the same room can stream the 4K files without any hiccup, yet the AppleTV can’t.

WiFi is about 80% voo-doo and the variables are often unseen. Have you tried moving the ATV to see if location could help? Sometimes even a few inches can make a world of difference. Different shelf or on one side or the other of another piece of electronics can often fix problems.

I will say, if you can run an Ethernet cable then that by far is going to be the most stable. I’ve see a rock solid WiFi connection go totally bad by closing a door in an adjoining room so it’s not always obvious as to what affects wireless signals.

Also as I said above the protocol could be the problem too. SMB 3 can cause buffering issues due to added security to each packet.

1 Like

Just an FYI.

I had major issues with my LG SJ7 sound bar interfering with wifi on Apple TV.

45 Mbps gives you 5.63 MB/s. which for most 4K movies is not enough. In fact its slower than a 100Mbs Ethernet connection

The WiFI is pulling 45MB/s, not Mb/s on my MacBook Pro in same room. This is from a local network monitor. My Internet speed test on the AppleTV is consistent at 250-300Mb/s which equals >31MB/s. This is from a gigabit Internet connection.

Ahh OK so its abt. 360 Mbps which also is not much for a 802.11ac WLAN enabled aTV 4K. My 5GHz devices pull about 750 Mbps in average from Wifi.
Are there a lot other Wifis around, that communicate on the same or nearby channels?
However 45MB/s should be more than enough to stream 4K, but I 've also connected the aTV via 1GB Ethernet in order to prevent buffering

If it works connected via Ethernet then it’s time to start looking at your wifi. More specifically some sort of high end mesh wifi with either wireless or wired backhaul.

Okay, I’ll post this one more time since it may have been overlooked in the earlier posts.

Check the protocol being used to connect to the share.

SMB can cause exactly your symptoms and can be corrected without having to run cables or buy new wifi equipment.

Two more explanations I can offer. Macbook Pro is 3x3 MIMO (Max 1.3Gbps) wireless while iPhones and Apple TV is 2x2MIMO (867Mbps). So you are already cutting speed by 1/3. That third channel being used by the macbook might be less congested that the other two when streaming to the ATV. Also macbook pro has much better antenna and can pick up data with a smaller signal strength. Even 10’ farther from the router in the same room could drop it a speed level (Mod/Cod).

Here’s a good site explaining speeds and inefficiencies of wifi:
https://www.duckware.com/tech/wifi-in-the-us.html

In general, though, not many people have been able to make 4K & Wifi work consistently and they would tell you not to bother and just go to Ethernet.

I had the same problems… I am using Google Wifi and a Synology DS218+ NAS.,The signal strength etc. is perfect… But still the 4K movies took a long time time start, had to buffer during playback and if I wanted to fast forward in a movie it took ages to resume playing the movie. The distance from the Router to the Apple Tv is only 5 meters, and there are no walls between.

I had no problem streaming 4K through Netflix and Itunes store, so i guess the speed of the wifi is no problem.

I resolved the problem by taking one of the Google Wifi units and put a cable between the unit and the Apple TV 4K. Now it all runs smooth, the buffer problems are gone, and movie starts up fast and there are no problems with fast forwarding in the movies… The connection from the first Google Wifi accespoint is still wireless to the accespoint that i cabled to the Apple Tv… Go figure! And then i configured the Infuse app to run SMB1.

I don’t know if the above info will help you, but my guess is that a MESH network/cable is the only solution…

Every mesh system is different. 4K Netflix uses less bandwidth than a 4K movie due to compression and other factors. The best way to determine Wi-Fi bandwidth is to run a local speed test between a client device and the NAS using iperf3. This will give you real world data transfer rates.

Google WiFi (and most mesh) caps out at 867Mbps, because it’s only 2x2. Other Infuse members have not had good luck with it + Infuse. A 4K Blu-ray can be up to 128Mbps, while streaming services are 25-35Mbps.

Good point. That could have been some of the problem.

Thanks everyone for the advice and feedback. I dropped a cat 6 cable from my gigabit switch to the 2nd floor bedroom AppleTV and problem solved :slight_smile:

Running ethernet is not feasible for everyone. My late suggestion is to do what I do for 1 bedroom and that’s use a wifi bridge. I have all ASUS equipment in my house, which has great software and use an asus router with 4x4 MIMO to connect to the main router with 4x4 MIMO using wireless AC. Which then acts as an ethernet bridge to my computer and ATV. I get full 100+MB/s speed from my gigabit NAS, even with a low wireless AC signal (1 bar).