4k Videos do not play on ATV4k properly

I can’t get 4k video to play correctly on my ATV/Samsung TV/NAS setup.

I am using Infuse Pro latest version on my AppleTV 4k. I have set my ATV to Frame Rate match on.

I have Plex running on a Synology DS918+ running the latest PlexPass server version. I bought Infuse because so many people have said that 4k “just works” for them when Plex has been problematic.

I have tried playing x264, x265, mkv, mp4, nothing will play right. I start the movie, it comes up (apparently in 4k, but I don’t know for sure – is there a way to see this in Infuse?) the first few video frames show up, but then the screen freezes. Audio will continue for about 10 seconds. Then playback freezes.

My network speeds seem ok. I ran a “speed test” in the Infuse library setup on the 4k files and I am getting 80+ MB/sec. If I look at Plex while the video is playing it shows Direct Play for both video and audio streams (that’s good, right?).

How do I go about troubleshooting this? I don’t know what steps to take next to get my media playing as desired.

I think the speed test is in Mbits/s, not Mbytes. Mine shows about 350Mb/s. If it’s indeed 80Mb/s it’s probably not enough, mine stutters at that rate. I run an ATV 4k with a Samsung TV (X75) and DS218+ NAS.

You’re going to get buffering at those speeds. How do you have your setup connected?

Can you check to ensure you are running the latest 6.3.1 update (scroll to bottom of Infuse > Settings)? The version had a few fixes to address an issue sort of like what you are describing.

Also, if you want a few test files (just to rule out this being an issues with a particular file you may have) there are a number of free 4K samples which can be found at https://4kmedia.org

I am also facing the same issue after the latest update 6.3.1. I am using Gsuite for playing movies.
This issue is happening for all the 4K files (and I have a lot of them). Earlier when I used to pause the movie for a minute or two, I could see the bar at the bottom that it downloaded/buffer movie for few minutes but it is not happening now. And now pausing the movie for a few minutes doesn’t make any difference.

I have already tried restarting Apple tv and speed test of 4K movies are showing average speed of 84Mbps.

Have you tried setting the Streaming Cache in the Infuse Settings to Legacy?

Yes, I already tried setting streaming cache to legacy from auto and the issue is still there.

This sounds like it may be a different issue than what the OP is seeing.

In order to use Infuse’s read-ahead cache, the Streaming Cache option will need to be set to Auto.

Also, you will need to have some free disk space available on the Apple TV, especially for larger 4K files. One way to free up space is to delete apps that you don’t find yourself using.

Thanks James, deleting the unused apps and setting the streaming cache to Auto fixed the issue.
Now, when I pause the movie for 2-3 minutes, I can see read-ahead cache is being used in Infuse.