4K HEVC HDR buffering constantly on Apple TV 4K

You don’t need to do it for the full file. Seems like something is majorly broken with your connection. You need 100+mbps for streaming. Try speed test for both WiFi and Ethernet. Maybe try different Ethernet cables. If your shield is working, how is it connected? Also try another file too

1 Like

Thanks for shedding some light on the issue @munpip214

On WiFi its very similar speeds.

The Ethernet lead is the one I used to used for shield but just switch it over once I got ATV.

The shield is now on Wifi and still plays smooth

Edit: Also for further information, trying other files yields similar results. Furthermore 720p and 1080p seem to play ok. It is mainly 4K and HEVC which are the issue for me… not sure why!

Is this 4K Apple TV or 4th gen?

1 Like

4K :slight_smile:

Have you tried restarting it?

1 Like

Those speeds are pretty terrible if they’re accurate. I average about 400Mbps from wifi infuse to my synology NAS running emby. Is the device hosting emby connected via Ethernet or wifi?

1 Like

What protocol are you using? SMB, FTP, DLNA, Etc

If SMB what version? SMB1, 2, 3, Legacy?

On the atv settings, under background app refresh if it’s on could you turn off all apps other than Infuse?

1 Like

It’s a server connected via Ethernet to a mesh point @JarvisMeier

@munpip214 in hope it was a software bug I just updated to the next TVOS beta. No such luck. Just playing 1080 wandavision no problem at all. So weird.

Will try background refresh setting, with regard to the rest, I didnt knowingly set any I just signed in through Emby API @NC_Bullseye

What version number of Infuse? What tvOS beta number?

I downloaded infuse today, so the latest? - Also, beta iOS 14.5 (public) @NC_Bullseye

I’d hold off on any major changes at least until Infuse 6.6.X is released since the tvOS beta has introduced issues.

Infuse has some fixes to be more compatible with 14.5.

Thank you. I had the issue before and after the update. I was just trying to eliminate variables. Not sure if I’ll ever get to the bottom of it.

If you are able to play some files but not others it sounds more like it is file specific. Can you try speed test on a few other things and see? 4mbps is too slow for anything. 4K ATV should have the power to play anything.

I’ll check it out. Thanks again @munpip214

You could also try resetting your mesh points. The proper way to connect things in a network where throughput matters is having all servers hardwired via Ethernet to either your router or a network switch connected to your router. Wifi should only be used to connect your end points/clients.

I second this facing the exact same issue with emby and remote FTP I can able to achieve max speed 15 Mbps on both FTP and emby server while my internet speed is 30 Mbps so somewhere it’s 50% speed throttled via infuse.

Someone also posted a similar issue here

P.S: i can able to stream 720/1080P just fine no buffer while this problem only existed with 4K HDR

Thanks for your replies everyone. I systematically tried each piece of the jigsaw until I found a solution. Unfortunately, emby was the issue. Trying Plex worked perfectly. Not sure where the incompatibility lies but I can be 100% certain I can watch buttery smooth streams locally again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.