#4K HEVC 10Bit Playback# Buffering Issue with Mac mini 2018 Plex Server

Hi all:

Newbie here and have some playback issue on 4K movie playback. Recently I got a 2018 Mac mini (i3 base version, 799$) and hoped it can handle 4K file playback.
First I tried to use Plex itself for playback but for most files, Plex always transcode them which is quite CPU intensive and cannot handle more than 3 streams simultaneously. Then I searched online and found that Infuse can direct play 4K content without transcoding. Purchased Infuse 6 pro online and it worked at first, but start to buffer every 1-2 minutes.

Currently, The ATV 4K is connected via Ethernet with the Plex server and the Plex server is currently running on the Mac mini and those 4K movies are stored at one external USB 3.0 HD connected directly to the Mac mini.

I’m trying to figure out what caused the problem. Is it because Mac mini is not powerful enough to handle these 4K files or it is due to the limitation of ATV 4K? The movie bitrate is between 30-70 most of the time.

Any help or suggestion is appreciated. Thanks !

Welcome to the forum!

Just to cover the bases, have you updated to 6.2.3? It was just released this afternoon and is still propagating to some of the update servers. It may or may not solve your problems but best to start troubleshooting with everything as up to date as possible.

Also, just fyi there’s a thread already running with similar issues here Some 4K movies stuttering on ATV4K. Maybe hardware/software limitation?

Thanks for your reply. Haven’t seen the update yet but will keep an eye on it once it’s ready.

I saw the other post and I personally does not have that movie. The problem is ALL movies I have they all stutter at some point. So there must be something wrong going on here. Just trying to figure it out step by step

The update should be available anytime now. It’s out for many but some are still waiting. Sorry about the link I meant this thread Apple TV 4K HEVC Buffering

Is the Mac Mini also connected to Ethernet? You will most likely notice buffering with 4k files if any part is on wifi. Also you might try putting a few videos on the hard drive of the Mac Mini itself. It could be the external drive if it is too slow.

You mention playing “3 streams simultaneously”. Are you trying to do that with 4K files and Infuse as well?

I have a similar problem but I have a very fast Mac desktop. So it isn’t a performance or memory problem. And I also never had problems until recently. Very strange.

Are there any parts that are connected via WiFi? If so would it be possible to test with Ethernet to see if that may be an issue?

So I’ve back for some update. It turns out that I returned my Mac Mini and switched to Nvidia Shield TV Pro(2019). I connected them as before and now it works pretty good without any buffering. I did try to watch different 4K movies on different devices at the same time and Shield TV can still do the job without any issue. So my conclusion is that Mac Mini, at least the 799$ version, is not suitable for this kind of job compared with Nvidia Shield TV.

So do you have the same setup as before just with Plex on Shield instead of Mac Mini? And now no issues to Infuse?

Yes. exact setup. Smooth playback in Infuse for 4K. In Plex native app, however, it is unstable and varies by different 4K video files. I watch almost exclusively via Infuse so it won’t bother me at all via Plex. The only time I need to watch via Plex is for those 4K movies on my ATV 4Gen which cannot handle them directly via Infuse. Conversion via Plex is the only solution I have for now if I want to stick with my ATV 4Gen hardware. I believe there is no conversion option for Infuse at all.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.