This only happens in infuse, not itunes 4k or same file over usb

Ju6500 is not the best for hdr, but it works with the firmware update, itunes 4K movies looks stunning and blurays remux on usb also looks amazing, this happens only when i play files on infuse with fire and explosions

You didn’t see ant difference in the fire on the attached screenshots?

That’s not what I’m seeing in all my tests, which is why I asked the question about it being in VUDU ported over via Movies Anywhere (MA); it’s been shown to only port in 1080p even if it says 4K. Infuse, iTunes 4K, USB, Samsung UBD-8500, NVIDIA Shield with Plex and Kodi, and the Xbox One S all have the fire looking exactly the same with either the 4K disc or my rip. The only thing that shows the fire different is if I play the Blu-ray, and that looks the same as what you’re seeing. I also played it in VUDU in 4K UHD with Dolby Vision with my TV app, and the fire was still more red than in the Blu-ray.

I can only conclude that that is the correct color that is mastered for 4K.

No man, this is a bluray remux, not vudu, not capture

And again i tell you, via USB the file plays fine, HDR looks stunning

This is not the color mastered for 4K HDR, this is wrong color handshake between infusion and our tvs (testd both samsung and sony 4k hdr)

You’re missing everything I’m telling you. Here’s what I tested that had the same color that you’re saying is wrong:
The actual 4K HDR UHD disc that I own in two 4K HDR UHD disc players (Samsung UBD-K8500 and Xbox One S)
iTunes 4K HDR
VUDU 4K Dolby Vision
Infuse 4K UHD Remux of my disc from above
NVIDIA Shield (with Plex, Kodi, and SPMC) with my remux of the 4K disc
USB on my TV with my remux of the 4K disc
Plex on my TV with my remux of the 4K disc

They all have the redder color. Every single one of them. The 4K is just mastered to a different color than the Blu-ray.

but you are not answering me why i cannot see the “red fire” via the usb port/samsung player, also i don’t see it in itunes 4K HDR version
and i’ve also tested on a friend’s sony hdr tv (not dolby vision). three different people were comparing certain scenes with fire in mad max and batman v superman, the red fire is only present on INFUSE, not usb, nor itunes 4K

btw, thanks for your interest and your time, u rock man!

perhaps your tv is dolby vision (mine is only HDR) and you don’t have that problem

as i understand, apple converts dolby vision to hdr

vandam00 and timstephens24 — I’m really enjoying reading about the troubleshooting you’re both attempting.

Have you seen this? (post from james on 11/17 in another thread)

“There are in fact some adjustments we’re making to the tone mapping algorithm to address some of the feedback we have received since the launch of 5.6. Stay tuned!”

You can hit the link to see the specific problem that the other user was having, but it basically comes down to contrast and color grading.

Perhaps this is the answer you’re looking for?

I’m pretty sure that’s for HDR to SDR, not HDR passthrough.

Correct. The tone mapping algorithm only applies when playing HDR video on an SDR screen.

We have seen a few cases where an SDR video has been converted (incorrectly) to HDR, which can cause some tone related issues, but based on the feedback in this thread it seems Infuse is displaying this particular video correctly, as expected.

We’d be happy to review this further if you are able to send in a sample.

ok, i will send 2 samples. one with apple tv 4K + INFUSE, the other one with samsung usb player (both in HDR)

Hmm, are you not playing the same file on both devices?

yes, sorry, same file - different players :slight_smile:

Hi James,

Could you review the sample i uploaded a few days ago ?
In my case, the files are note converted from SDR to HDR but i still have this contrast issue.
I tried about 6 different movies (native HDR or Remux) and they doesn’t look ok on my Samsung HU7500 TV (non HDR).
I really want to stay with HDR files (even if my tv is not compatible and use Infuse HDR=>SDR conversion) because of the much smaller filer size.



I have tried more sample files (including remux) with the lastest 5.6.2 update…still having the same issues

it seems that when the topic is solved we never have a chance to get an answer, my issue is still unsolved

Please see this post for an update.

and some people call me crazy, but… i know that colors wasn’t showing fine.

Another quick update!

We’ve identified 2 issues that are affecting some videos and TVs.

  1. For certain HDR videos, colors are not getting passed correctly. The effect of this is somewhat subtle, but it’s something we are in the process of fixing.
  2. The Apple TV is not correctly setting the HDR video flag required by some TVs. This is more of a bug/limitation in the current tvOS software, but we think we’ve found a way around this. Fix also in progress.

Thanks for your patience.


How can I become a beta tester ?

I have a this devices

Apple TV 4K
iPhone 6S

Thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.