4K HDR Movies playing back in SDR

even though 4K HDR @ 60Hz is being ‘forced’ in settings, and Match dynamic range is off

Welcome to the forum!

Can you provide a bit more info on the video being played (perhaps send in a sample at: https://firecore.com/upload)

If the match options are disabled in Settings, Infuse won’t have the ability to switch the output to SDR.

This started for me as well, with the last release. Before that, HDR movies played fine. Another Apple TV App plays them as expected, so it’s not Apple HW/SW related.

I’ve been having this issue as well, but it comes and goes. I have my Apple TV set to match dynamic range, and it functions normally in Plex and Netflix. At first I wondered if Infuse just wasn’t showing the HDR badge, but I confirmed last night that it was showing in SDR, because pressing the settings button on the TCL 65R615 showed “Movie mode” when it should have shown “Dark HDR.”

Is this happening with all your HDR videos, or just a few of them?

Would you mind sending in a quick report so we can look into this?

All the ones I tried. Sometimes, changing the Apple TV Match Frame rate setting to off fixes it temporarily.

Like Dave said, it’s all of the ones I try, but the tricky part is that it’s inconsistent. Sometimes it works, sometimes not. Last night I tried rebooting my Plex server (Windows 7, i7, 16gig), and then Infuse displayed HDR again.

This would seem to put the blame on Plex, yet these titles display in HDR on the ATV Plex client when Infuse doesn’t.

I’ve sent the logs and the ticket number is 117283. Thanks again.

every single 10-bit HDR movie (HEVC h.265) I have is playing in SDR, and only in Infuse 6

I have no problems viewing HDR shows on Netflix and Prime Video

The report will help figure out whats going on.

I just submitted a ticket for this as I am having the same issues.

Here is what I have seen.

“Hello I am having intermittent issues with HDR movies in Infuse playing in SDR as other are reporting.

All of the movies that are HDR either work or don’t.

I have the Apple TV set to match content dynamic range and frame rate.

When this is happening all other sources are displaying HDR properly MrMC, Amazon,Netflix shows Dolby Vision, and ITunes shows DV or HDR. ”

I just rebooted the Apple atV and now all of the HDR movies play correctly in Infuse.

I had this very same issue as well on Pro 6, rebooting APTV 4K didn´t fix it, so had to uninstall and install Infuse.

Working fine since then.

This didn’t fix it for me. Nothing is playing in HDR. I’ve rebooted the Apple TV, the Plex server, and re-installed Infuse twice, and STILL none of my 4K content plays in HDR. It DOES play in the Roku Plex app on my TCL Roku TV, as well as the Plex app on the Apple TV. The Roku can handle .srt subs, not the ATV. Remind me why I’m paying for Infuse again, please.

My patience ebbs away, bit by bit.

Just for the purposes of input (not to suggest anyone’s “wrong” :slight_smile: the small collection of HDR10 video files I have here are all playing back in HDR as normal. In case it matters, the Apple TV 4K is connected to a Pioneer VSX-831 receiver and then on to a LG B7 OLED TV.

Are you using Plex, or a network share?

My Apple TV 4K is plugged directly into my TCL 65R615. Both are hard wired to the router. And playing titles in HDR is inconsistent. Sometimes it works, sometimes it doesn’t. I thought that rebooting the Plex server did a temporary fix, but that may have been a coincidence, as trying it again yesterday didn’t work.

The only issues I have are the 1080p HDR Netflix rips. Other than that all 4K HDR plays flawlessly. Running through a Sony str dn1080 amp into lg oled b7p

Infuse 6.0.7 with a few improvements in this area is now available. :slight_smile:

updated to 6.0.7 - no change
restarted my Apple TV - no change
deleted and reinstalled Infuse 6.0.7 - no change

the issue I’m facing is all my HEVC x265 10-bit HDR MKVs have serious color banding in dark scenes, which is what you get when you try to play SDR content in HDR

playing the same videos in SDR, they appear normal - but what’s the point of having HDR content if you can’t watch it in HDR?

also, I notice that switching back to Infuse which has a video playing, the image will initially appear normal then seems to have a screen/filter applied to it that causes the banding

That almost sounds more like a TV setting instead of an Infuse issue when you can switch back to Infuse and it looks normal for a bit. Maybe your TV has settings that are conflicting with what the ATV is sending. All of my 10bit 265 HDR content looks great with no banding at all.

Is your TV actually reporting SDR instead of HDR or are you going by looks only? Any hints on the TVs info display when playing a HDR video?

Which model TV do you have?

Can you check the Chroma setting (Settings > Video and Audio) and set to 4:2:0 and see if this makes any difference for you?

TV reports the content as being played in HDR. but the banding is exactly how it looks when you try to play SDR content in HDR…except the content I’m playing is HDR.

most of the time I output to my Dell U2718Q 4K monitor, and have not had issues in the past - in fact if I play the same content on my PC I can watch it in HDR with no issues, so it definitely isn’t an issue with my display.

yes I’ve tried the chroma settings but there’s no difference