4K HDR buffering every minute


recently I encountered a problem using Infuse 6 Pro on Apple TV 4K.

4K HDR movies just keep buffering every minute or so.

I have 500/500 Mbit/s.
Apple TV connected via CAT6 Gigabit cable.
Windows PC with content connected via CAT6 Gigabit cable.

I ran speedtest on Apple TV and it showed 460/470 mb/s.

When I ran speed test in Infuse it showed ~60 Mb/s for streaming. Why so?

Shares in SMB, port 445. Tried every option from Auto to Legacy.

I probably add that buffering comes to 4K HDR content I viewed without problems in the past. I haven’t changed anything in my setup.

Any info?

Try using an FTP share.

1 Like

It doesn’t show such option. SMB is grey.

You have to create a new share for FTP protocol.

Now I’m using Emby, before Infuse had support for Emby, using FTP I got the best results.

I don’t have one (?)

Is this a prerequisite to use Infuse for 4K HDR content?

No, many people have no issues running SMB for 4K HDR. I can play those without a problem on my SMB shares.

It’s just a way to try another protocol that has worked better for some.

You may have to enable FTP on your server to get it to show up in Infuse or you can enter an FTP share manually also. You can refer to the users guide here on how to create a FTP share in Infuse.

I know, I was one of these people myself until recently. I wonder what have had changed.

The link you provided doesn’t inform on setting up FTP share.

You have to use the “Other” option

Remember to install an FTP server on your computer, FileZilla is a free option.

1 Like

Another option is install Emby for free to manage metadata, Infuse syncs with Emby almost immediately, and http streaming performs very well. I have tried Plex, SMB shares, NFS shares … and with Emby I have had the best experience.

Yes, there’s no explanation.

I failed to link emby share (button “Save” is grey in Infuse) and Filezilla asks questions I’m not qualified for.

The biggest mystery to me is why it worked so great before. Been a user for 3 years.

Just out of curiosity, what do you have the Streaming Cache in the Infuse settings set to?

Also, when you watch a 4K HDR movie, if you pause can you see the buffer filling in the time bar? Will it play correctly if you pause, let it buffer a few minutes and then resume?

You may want to try replacing the Ethernet cables one at a time too. They don’t always just fail completely. It could even be poor contact in the connectors.

Thank you for suggesting cache settings check. I will look tomorrow.

I have replace cables the day before, all of them and also hdmi, to clear that first.

Check your PC, maybe you have something wrong there and it doesn’t perform as before.

You may try adjusting the SMB version setting in Infuse. Try SMB 2 and/or Legacy.

SMB3 supports (optional) full packet encryption, and if this somehow got enabled on your PC it will slow things waaay down. Plus, this encryption isn’t really needed for local streaming.

SMB2 worked until 13.03. Now not a single SMB option works. Starts loading every couple of minutes or so.

Do you have any new ideas?

The speed test in Infuse will test the connection from Infuse all the way to the device or service you are streaming from.

Speeds of 60 Mbps is a bit on the low side, so buffering with some 4K videos may happen.

Since you are getting higher speeds with the speed test app on the Apple TV, that seems to indicate the connection from the Apple TV to your router is ok. I probably look at the connection from the router to your source (change cable(s), router ports, etc…) to see if that makes any difference in speeds.

Changer cables and ports. No change in perfomance.

I randomly run tests when I’m on the right mood, and today I noticed speeds were up to 98-100 mbps when my daughter was playing online. When she quit her game speed dropped to 50 mbps.

What does it mean? Windows blocks traffic? Has anyone with Windows 10 solved a similar problem? I think I have read the whole internet to find a solution.