4k buffering

Hi!

I have Infuse Pro 5.95 (2442) and an extensive library of 4k HDR content. Most of the movies are 40-60gb. My ATV 4K is wired. Until 2-3 weeks ago, I could play every file in my library without a glitch. I have a variety of shares NFS, UPNP and SMB. NFS and SMB both buffer terribly. UPNP works no problems. I have SMB set to auto, and I have tried going through all the settings and Auto and Legacy are the only ones that work. Both buffer. NFS seems a little better, but the best that either will do is about 10 minutes without buffering.

I could use UPNP to do everything, but the problem with that is the movies don’t add to my movie library and the only way that I can play them is to browse the drive manually and select the movie I want. My TV will do the folder browse thing, and I wouldn’t have needed an ATV 4k or Infuse to play my videos. I want to take advantage of Infuse’s strengths and have my videos in my movie collection.

I have tried every setting and read every article on the Internet and nothing I try has made any difference. Does anyone have any idea why I’m having NFS and SMB problems but UPNP works no problem? Can the video on UPNP shares be pulled into the video library?

One thing you may try is adjusting the SMB version in Infuse as described in the link below. Some users have had better luck with SMB2 or Legacy.

Additionally, the upcoming Infuse 6 release will include a number of big streaming improvements which can help in cases of inconsistent network speed.

Thanks James. Do you have any idea on how early in 2019 it will be released? :slight_smile:

We’re tentatively planning for early/mid March. :slight_smile:

I’m having the same issue since a couple of weeks. Every couple of minutes 4k HDR 50-70mbit videos buffer like crazy! Used to be very fast with loading and fast fowarding etc.

I’m having this issue with SMB shares and with PLEX (connect option, haven’t tried the DNLA)

I tested the wireless network with speedtest and thats around 300mbit so should be fine (wired is 100mbit max)

Anything changed in a recent update that might have caused this?

Have you tried changing SMB to either “2” or “Legacy”? Also, there may be something else on your WiFi that is polling every so often and causing the buffering. Some apps can cause that. Personally I’d stay away from DLNA since it has it’s own burdens and glitches.

Thanks NC Bullseye. I am running in Legacy and I just went back and tried SMB2 and it doesn’t work. My system only works with SMB set to Auto or Legacy. I am wired, so I know that my problem isn’t a lack of bandwidth and I’m running to a computer that I know has more than enough horse power to supply the data I need. I never had issues until somewhere between 1 and 2 months ago now. I also have a Himedia Q10pro running Kodi that does not buffer or glitch at all and it is going back to the exact same computer for data and it is using the exact same SMB protocols. I’m thinking that a new version of Infuse caused some sort of issue. It is VERY frustrating. I like Kodi, but I LOVE Infuse (or I did any way). Hopefully this all gets cleared up with Version 6.

Thanks for the input NC Bullseye. But my wifi is actually really strong and can handle a lot. For example watching 4x 4k videos on 4 different devices at the same time with vlc = no problem. And yes I tried SMB 2 and Legacy. Legacy seems a bit better but still not fast and buffering. Used to be lighting fast on SMB auto or Plex share. With no buffering at all… just initial loading which is now really slow.

Have you tried FTP? FTP has less networking overhead. It’s actually 2x faster on my old android tablet over the exact same router on the same tablet, by just copying data using the same app over FTP rather than SMB.

No haven’t tried FTP as I don’t have those shares available when I try to add a new one. AFP, SMB, PLEX DNLA, PLEX Connect and UPNP.

What kind of NAS do you have?? My QNAP has FTP disabled by default, but all I have to do is click on a checkbox to enable it.

I don’t have a NAS. I have a mac pro “server” running macOS. I’ll try and work out how to get SFTP running and do some testing…

Hoping Infuse 6 will solve all his though… cus I normally don’t even use the SMB shares. I have my library running on PLEX. And that protocol can’t be configured. Which was fine a while ago but now buffers like crazy.

For quick weekly TV shows or movies I don’t keep I use my Apple Airport TimeCapsule (SMB only, on Legacy now)

Oh I see. FTP is unencrypted so it has the least resource overhead, but apple doesnt like to support it anymore, instead favoring sftp.

You can also try NFS.

Oh I know everything about the Apple FTP and SFTP thing…
It’s just annoying that it all stopped working properly cus Infuse was my favourite app to watch movies and TV shows… That’s why I bought the subscription :wink:
Now I have to use VLC which is ugly and not user friendly.

There are a lot of thing I can try… I know. But I mainly use Infuse with the Plex Library … there’s nothing I can change with that share unfortunately.

Version 6 did not help the buffering issues at all. 1080p and below stream fine. 4k buffers about every 2 minutes on this version. I have an android box sitting right beside it that doesn’t buffer at all on the same content. This was not a problem until some months ago. Very dissapointed.

Yep! Same here… VERY DISAPPOINTING indeed!
Weird that a couple of months ago everything loaded faster, ffwd/rwd faster and didnt buffer at all.
I’m even getting buffering with high bitrate 1080p now with Infuse 6! And if I play the same content through the Plex app or even through the Plex share on Infuse it loads instantly and plays flawlessly…

oh and please set this topic to UNSOLVED !

I agree with Martin. This is not at all solved.