4K buffering issues

Hello guys,

I have been using infuse for over one year now and it have been working VERY good.
I have mainly been watching 720 and 1080 content from a USB-drive connected to my router to an Apple TV4K (wierless).
A couple of days ago i rented a 4k HDR movie and now i cant watch 720 and 1080 content anymore :slight_smile:

So i transfered an UDH movie to my USB-drive. Started it on the Apple TV4K-infuse and it have to buffer every 2-3 minutes.
I cant use the backward-forward thing since everything just starts buffering and will take 30 seconds to start the movie again. And then goes back to buffering again. So this morning i have been troubleshooting to find a solution for this.

First i connected the USB-drive direct in to my TV (LGOLEDC7). The movie worked perfect.
Then i shared the movie from my PC direct to the Apple TV4K and Infuse. And it worked like a charm. I could even fast forward without any buffering time. The PC is on a cable-connection to the router but the Apple tv4k was still connected with wi-fi.

So, do you guys think this problem comes from the router or the usb? Since everthing worked when i shared the movie from my pc the problem must surley come from the USB?

I do have to say that both the router and the USB drive are kinda old and im not that familiar with network-setups.
In the asus router-menu i have activated Network Place (Samba) Share / Cloud Disk and everything have been working untill the 4k movies.

I have a Asus router - RT-N56UB1 : https://www.amazon.com/Asus-Dual-Band-Wireless-N600-Gigabit-RT-N56U/dp/B0049YQVHE
The USB is formated in NTFS and is this one: https://www.amazon.com/500GB-Elements-Portable-External-Drive/dp/B00CI3BISU

Visited an apple store and a guy there adviced me to buy an Apple airport and tought that would help me.
If that would fix this i would problably buy one because it sounds very easy.

Sorry for the long message.
Best regards

Welcome to the forum!

There are a few things you can try before picking up new hardware.

  1. Adjust the SMB version in Infuse as described, as some devices perform better when using a lower or legacy setting. Streaming From a Mac, PC, or NAS – Firecore

  2. Try connecting the Apple TV via Ethernet. Often times this will allow for better performance when streaming 4K.

Tried ethernet and it did not help. Switched smb version to legacy and now everything works awsome.
What does the ”SMB Version” actually do?

Thank you very much for the help! :slight_smile:

The problem is your router’s USB read speed is too slow. On a good day, the best it can muster is 13 MB/s as tested by smallnetbuilder(ASUS RT-N56U Black Diamond Dual-Band Gigabit Wireless-N Router Reviewed - SmallNetBuilder), but that depends on various factors. The processor in your router is too slow. Sometimes he has to test several different USB drives to get the best speed. You can test this by using your computer and copying a file onto your PC, see what the transfer speed is.

Your best bet is to get an actual NAS with a decent processor or upgrade your router. The airport extreme was designed in 2013, it’s performance is not much better than your current router. Personally I use a NAS, you could just use a spare computer and share a folder on there to do a proper test and process of elimination.

Did you miss where the OP said that switching to “Legacy” SMB fixed the issue? It sounds as though their router is working for them.

Oh my bad, I did miss that.

FWIW, I have had issues since the 5.8 update where I was not able to play most MKV (1080p) files the video would play for less than 10 seconds then would be stuck on a black screen with a buffering icon.

I have since changed the SMB setting to legacy as suggested and the issues seems to be resolved.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.