44.1 kHz audio output (tvOS 17 + 2022 ATV4K 3rd Gen)

Setup
ATV 4K 3rd Gen | tvOS 17.0 | Infuse 7.6.1 (Plex) —> Marantz SR7015 —> LG OLED C7
Audio Options ATV/tvOS: Audio Format Auto, Atmos Available | Audio Mode Auto
The sample rate information is from the media/playback information of the Marantz SR 7015.

Dear Infuse Community,

with my recently purchased ATV 4K Gen 3 I made - rather accidentally - the strange observation that both with Infuse but also with (almost) all other video/streaming apps (e.g. Youtube, Netlflix etc.) the stereo or multichannel audio track also re/downsamples to 44.1 KHz when de/transcoding to LPCM.

This behavior only does not occur if

  • a Dolby Atmos (transported in EAC-3/DD-Plus) audio track is played (correct playback of the 48 KHz sampling rate, both when playing back via Infuse but also, for example, when playing back a corresponding title with Dolby Atmos sound on Netflix),
  • playing back songs on Apple Music (even the correct sample rate switching works here, i.e. songs with 16 or 24 bit | 44.1 KHz are played back with 44.1 KHz; songs that are also available in High-Res Lossless are played back with 24 bit | 48 KHz; albums and songs that are available in 3D Audio/Dolby Atmos are played back with 48 KHz accordingly,
  • (the same) videos are played back with MrMC (Plex), in this case the audio track is played back in the original sample rate of 48 KHz.

Unfortunately, I can no longer determine whether this behavior is related to the update to tvOS 17.0, since I bought the ATV 4K 3rd Gen only shortly before the release of tvOS 17.0 and have already installed the latest tvOS version very soon after its release.

However, I also still own an old ATV 4K 1st Gen, with which I tried something around today and wanted to check whether the behavior described above can be reproduced during audio playback. Both with tvOS 16.5 still installed on it and after the update to tvOS 17.0, all audio tracks were played back in 48 KHz, regardless of whether LPCM or Dolby Atmos incoming. Even the songs played via Apple Music are always played back at 48 KHz - the old familiar behavior, because as far as I know the audio output of the ATV has always been limited or fixed to 48 KHz, regardless of the incoming sampling rate.

I would now be interested if anyone has made similar observations and can reproduce the described behavior with the latest generation (3rd Gen) of the ATV 4K from 2022? Of course, I would also be happy if this problem/behavior could be fixed in the future. However, I have the impression that it is due to tvOS and therefore probably cannot be solved by Infuse/Firecore alone.

Thank you very much for your support.

1 Like

I’ve noticed similar behavior on Infuse with the latest tvOS 17 update and DTS-HD /TrueHD media playback. I’ve also updated to tvOS 17.1 last night with no change and am on the latest Infuse Beta. Hopefully this is not something that impacts LPCM conversion and we still get the lossless audio.

Any devs can confirm what the sample rate and what is happing perhaps?

Same here 44.1KHz output as well in infuse with appletv 4K 3:rd and TVOS 17.1 on 48KHz material.

Can appletv 4k 3:rd finally output 44.1 KHz and infuse needs an update? Something on default in the SDK perhaps?

I’ve been noticing some weird audio artefacts, starting around the time I installed tvOS17. I’m now wondering if this is the explanation.

I also have an Apple TV 2022, LG OLED, and Marantz receiver. Can I ask how you’re seeing the audio sample rate? Where should I look for this information?

On my Denon, once the movie is playing on the remote I hit Setup > General > Information > Audio should be similar on your Marantz

1 Like

I have a Meridian 861V8 preamplifier and it clearly states the source KHz and number of channels on the display.

There is probably somewhere bitrate or samplerate/channels are displayed on your A/V receiver menus.

1 Like

Either as described by UncleBabyBilly or you click in the Marantz AVR Remote App on the question mark (as soon as a movie is playing) → AVR Information → Input.

The update to tvOS 17.1 did not bring any improvement/change for me either.

1 Like

I did some testing here, and was able to replicate this on the 2022 ATV4K. On the 2021 ATV4K the audio is sent as 48kHz, as it always has been.

This is affecting other apps such as Netflix and Apple’s own TV app when 5.1 (non-Atmos) audio is sent. The same thing also happens when AirPlaying 5.1 (non-Atmos) content from the TV app to the Apple TV.

When playing E-AC3 Atmos audio in Infuse (and Apple TV) the correct 48kHz audio is sent.

Forcing the Apple TV to send Dolby Digital (change Audio Format setting in Settings > Video and Audio) also sends 48kHz.

We’ll need to dig into this to see if there is anything we can do from the Infuse side, but the fact the TV app and AirPlay are also showing the same behavior seem to indicate this may be a system level bug that would need to be fixed by Apple.

Test environment

  • Apple TV 4K (2021 and 2022 models)
  • tvOS 17.1
  • Infuse 7.6.2 (uses tvOS 17 SDK)
  • Yamaha RX-A1080 receiver
  • Sony XR75X95J
  • RUIPRO 8K Fiber Optic HDMI (48Gbps) cables
1 Like

I’m experiencing this too.

And I found a couple of threads about it online:
https://www.reddit.com/r/appletv/s/1rlIDtVKHJ
https://discussions.apple.com/thread/255233474

I’d suggest to everyone in this thread to submit a bug report to Apple: Feedback - Apple TV - Apple

1 Like

Hi, this is my 1st post so I would like to thank you for making InFuse. I love this App so much and I’m recommending it everywhere :innocent:.

I’m encountering a similar problem with my ATV 4K (3rd Gen). Any news on fixing the issue of getting 44.1 kHz instead of 48kHz?

It’s an Apple bug, not an Infuse bug, see above.

Updated to tvOS 17.2 Beta and the issue is still present.

3 Likes

Latest Developer Beta 17.2 released today is now reporting 48 kHz via Denon Receiver on TrueHD and DTS-HD Master files.

3 Likes

Unfortunately for my setup, the new beta today has not fixed the issue.

On this ATV, Audio Output is set to Stereo and it still will only do 44.1k.

Apple TV 4K (2022) / tvOS 17.2 (developer beta 3 / 21K5348f)

1 Like

Confirmed!

In a few quick tests, this appears to have been resolved for multichannel PCM audio in tvOS 17.2 b3. All audio is now passed correctly with a 48kHz sample rate, which matches the source. :raised_hands:

However, the sample rate still is still incorrect (44.1kHz) when forcing 2.0 stereo output.

1 Like

Thanks for confirming, @james

Just to clarify, the issue still existing with 2.0 isn’t just when forcing it as an output. Even when ATV Change Audio Format is Off, 2.0 material is 44.1k from any app.

It is because of another, even more annoying audio bug in tvOS 17 that I do currently have my ATV set to force 2.0 output. Ever since tvOS 17, if I watch something in 5.1/7.1 from say Infuse, then the ATV stays in the multi-channel output mode even for system sounds and other stereo apps like say YouTube or Twitch, etc.

The ATV takes the 2.0 sound from those apps and pushes it into the L/R channel of a multi-channel signal. But then it sounds unnatural and cannot be properly upscaled from 2.0 to a 5.1 speaker setup by the receiver.

The only workaround was to go back into Infuse and play something 2.0 before going into other apps every single time, so it became easier to just force 2.0 in the ATV settings for the time being as this bug is even more bothersome than the 44.1k issue.

Not sure if anybody else has previously brought up this getting stuck in multi-PCM issue in another thread.

1 Like

Yes, I can confirm this as well. What is interesting is the 2.0 PCM output when browsing the Apple TV menus (IE click sounds) is 48kHz. :man_shrugging:

This is a separate issue, and seems to be system bug. Others (non-Infuse users) are reporting this on Apple’s forum.

The issue is not only related to Apple TV and tvOS. I noticed the issue on:

  • Apple TV 4K tvOS 17.1.1 connected via HDMI to Denon AVR-X6700H
  • Apple iPad Pro iPadOS 17.1.1 connected via USB-C to Cayin RU6 (USB-DAC)
  • Apple iPhone 11 Pro iOS 17.1.1 connected via Lightning to Cayin RU6 (USB-DAC)
  • Apple iPhone X iOS 16.7.2 connected via Lightning to Cayin RU6 (USB-DAC)

Playback of stereo audio via audio apps like Tidal, Apple Music, Spotify or broadcaster apps like ard-audiothek is working fine and dynamical with 44.1, 48, 88.2, 96 kHz (when maximum quality is choosen in the app).

Playback of stereo audio via video apps like Youtube, AppleTV, Amazon Prime or broadcaster apps like ard-mediathek is downsampled to 44.1 kHz, although they are published in 48 kHz.

The downgrade of audio quality is perceptible with high quality audio equipment and decent hearing ability, compared to playback on Windows or Android with the same DAC.
You might check with this short Video with Audio in AAC-LC 256 kbit/s and 48 kHz. You can stream or download the video here: MediathekViewWeb
Using the streaming or download option, the audio will be played with 48 kHz. Same, when using Safari Browser and access https://www.ardmediathek.de/
Using the ARD-Mediathek app will result in a playback with 44.1 kHz. Even after update to OS version 17.2
Using Infuse Pro 7.6.4 on iOS, the downloaded file will be played in 44.1 kHz, using VLC app on iOS, the file will be played in 48 kHz.
So it seems, that there is an issue or a change of the API on Apple OS for several Apps playing video content.

Information on samplingrate or upmixing can also be gathered by the Denon AVR remote app under “AVR-Informationen” and a Denon AV Receiver. Unfortunately the sampling rate is not displayed when using Apple Airplay.

3 Likes

tvOS 17.5 released today and all of these audio bugs are still present from my testing

@james Please keep Infuse compatible with tvOS 16 if possible for those of us keeping our main home theatre ATV on it to avoid these issues.

Thanks all.