4.4.4 to 5.2 untehtered

Hi,

 

So I have read all the help, but no luck.

 

I have an ATV2 Black running 4.4.4 jailbroken, but would like the newer features on 5.2 but can’t seem to work it out. I first followed the support pages advice and can see SHSH ‘blobs’ as you call them listed when I run ‘Tiny Umbrella’ I think?:-

  • AppleTV2 4.4.4 (9A406a)
  • AppleTV2 5.1 (9B179b)
  • AppleTV2 5.1.1 (5.0.1) (9B206f)
  • AppleTV2 5.1.1 (5.0.2) (9B830)
  • AppleTV2 5.1b2 (9B5127c)
  • AppleTV2 5.1b3 (9B5141a)
  • AppleTV2 6.0 (5.1) (10A406e)
  • AppleTV2 6.1 (5.2) (10B144b)

I have also tried to run Seas0npass by right clicking on the ‘Create IPSW’ and selecting the 5.2 option listed…but no luck. I get to the scripting that runs iTunes, and then nothing happens? I have to manually press ‘Restore’ and then it finally fails at the end saying ‘Error 11’.  Weirdly, when I plug the apple tv back into TV, it boots up fine back into 4.4.4???

I assume I’ve missed something here?

 

Any ideas?

Thanks very much in advance. Great website!

 

Hmmm…might I be right in saying that as I’ve not upgraded from 4.4.4 to 5.2 within the period when Apple was signing 5.2, then my option is only 4.4.4 untethered or 5.3 tethered?

I get this I think now, but why do I see the list of SHSH / versions on Tiny and Season then?

If you had ATV Flash installed and used its backup options then it may well have saved blobs for releases that Apple was signing at the time you did the backup. If you go into the Maintenance app and select the option to save firmware signatures you will be shown a list of what signatures you have saved.

I suggest you use iFaith to see what firmware blobs are available (if any) for your device within the cloud. If there is a firmware blob then you can download it then use snowbreeze to make a custom signed IPSW.

I assume those applications are on a PC then? I was using a mac, but could use a windows laptop…will try and report back…

As for the maintenance settings, I did save them and it’s coming up with the whole list including 5.2.

The strange thing is, I don’t think I ever upgraded the software from 4.4.4, so how can this be?

You can therefore go to any of those releases.

The ATV Black firmware signature backup process saves the shsh blobs for any releases that are being signed at the time regardless of the release installed.

 

Whenever you use the Backup My Firmware option in Maintenance it will save any versions that Apple are signing at that point in time.

So if you did a backup when Apple were signing 5.2, even though you were not actually running that version, then the 5.2 version is added to the saved list.

Ok,

So assuming my SHSH blobs are intact for say v 5.2 (last stable untethered update),
How do I upgrade?

Is it as I tried before? I right clicked on Seas0npass ‘create IPSW’ and selected 5.2 from the list.
It’s just it didn’t automatically restore through iTunes? Am I doing something wrong?

The only thing I can think to do is find the patchedIPSW file after Seas0npass has made it and then
Select restore with ‘option’ key to browse to location of the IPSW file.

Any pointers? This has been v helpful so far, thank you .

This is the way I do it using iFaith and Snowbreeze as described in this thread…

I find it not that unusual for the automatic restore to not work

The only thing I can think to do is find the patchedIPSW file after Seas0npass has made it and then
Select restore with ‘option’ key to browse to location of the IPSW file.

This is what I do when SeaonPass does not start the restore automatically. Make sure you select the IPSW file with _SP as part of the filename as that is the jailbroken one.

Thanks,

Where on a mac (folders) does seas0npass store the jailbroken IPSWfile.

No idea off-hand as I use Windows. However I am sure it has been mentioned lots of times in the forum if you search hard enough.

I think I found the answer here:-

Will try and report back tonight.

:wink:

Right. Some progress.

 

Found the Documents/Tether/ folder and the IPSW files. Tried again, but can’t get the bugger into DFU mode now! Consequent Error code 21 from itunes…

 

I’ll get there…

 

EDIT: 2AM! > Got it into DFU mode by folloing others advice:-

 

1) Connect ATV2 up to a power source (contrary to the instructions)).

2) Open iTunes

3) Hook up the micro USB.

4) Then remove the power cable (standby light should be blinking), wait a second or two and then press 'menu' and 'pause' together for 7 seconds.

 

But, now I've been getting Error 1600 and 1657 form itunes and no luck (using the Restore... button with option key and selection the 5.2 IPSW file in the Documents/Tether folder.....) 

 

I'm out of options here....I plugged the Atv2 back in, and everything is still working on 4.4.4 and maintence still assures me I have SHSH for 5.2!

 

HELP! Maybe I'll try the PC instead of Mac.

Success!!

Would you believe it!? Using the same method, but on my old Windows PC. I can confirm that Seas0npass does not work (definately not spawning iTunes correctly with it’s script). This all happens faultlessly on PC, allthough it was unable to save SHSH files as it asked me to do to start with.

 

For the Seas0npass team - failure on Mac OS 10.8.4 with iTunes 11.0.4, but success on Windows PC with iTunes 10.7.0.21 (I puposely did not upgrade iTunes yet here).

 

I can see the FC logo on setting icon…I’m ready to go…

 

Wahoo!

Has anyone else experienced this problem on Mac OS X with Seas0nPass Version 0.9.3 (730)??

 

ABSOLUTELY, gavatv.

I posted this issue over a month ago when I had nothing but FAILURE using my brand new Macbook Pro (which had worked fine with SP 9.0), and nothing but SUCCESS using my old Windows PC.

I have totally given up on using my MAC for Seasonpass purposes and pity those individuals who simply own a MAC.  They are stuck at this point.

I’m honestly dumbfounded that with such an obvious issue apparent for months, nothing seems to have been done for MAC users to solve it.

I’m glad you discovered the key to this kingdom by using a PC.

 

Moderators/Seas0nPass authors…any comment. Please?

I have jailbroken both my apple tv’s 2 with my MAC I didn’t have any issues at all. With one of the apple TV’s I went from 4.3 to 5.3.

Jailbreaking an untethered version into a tethered version is not what I had in mind when I chose to use Seasonpass with my MAC. 

But since SP 9.3 on my MAC would NOT save signatures no matter how often I tried, I chose not to convert my untetethered version 5.2 into tethered version 5.3 – which I guess was possible, and evidently what you did on your 4.3 ATV.  Instead, I used my PC which completed the jailbreak flawlessly with version 5.2.

By citiing that you jailbroke a 4.3 and converted it to version 5.3, you have not yet established that SP 9.3 on the MAC saves signatures.  Does it? Anybody?

And as an aside:  Why would you want to convert your UNTETHERED 4.3 version into a TETHERED version 5.3?