4.4.3 Backups not working

I just updated to 4.4.3 and when I try to restore a backup the screen flashes black and I’m returned to the home menu. The same thing happens when I try to create a new backup. This happens on both normal and full backups.

Encountered exactly the same problem. When trying to restore from Backup the screen flashes black and the main menu is shown.

I also cannot send diagnostic data. Same behavior as stated above when trying to create a backup. Support ticket has been opened.

Are you using Overflow?

Yes I am. Is that the source of the problem?

Most likely yes. Try moving Maintenance out of Overflow, and that should resolve your issue.

Maintenance is not in Overflow, nor is Media.

Hmm - any other 3rd party software installed?

Nothing, just Overflow.  I did install Overflow via nitoTV, so all the default stuff that nitoTV installs like SSH and Updatebegone.

Same problem here, since updating to 4.4.3. As soon as I try to restore a backup, the device appears to restart and I’m back at the home screen. No 3rd party software installed. Maintenance and Media Player are all I have.

Same here… I submitted a report.  Mine is even worse… FRESH install of 4.4.3 iOS with SeasonPass… NOTHING else installed excpet ATV2 Flash (black), then the media player.  I can’t pick Backup Settings without this blackscreen/restart… I can’t “Send Diagnostic Information” without a blackscreen/restart.  This 100% happens everytime I pick either of those actions.  Sometimes just navigating the menus does this… the only thing these have in common that I can guess at is they all involve internet access (menus when getting metadata maybe?).

Let me know how to grab the diagnostic info manually and I’ll attach it.  You probably have something here in the forums but I couldnt’ find it.

Yup, I can’t submit diagnostic info either, same problem. I hadn’t tried it until I just read your post. Glad I submitted my diagnostic info for another issue I’m having before I updated to 4.4.3.

Sorry guys, this was a silly oversight on our part. A new version of Maintenance is on the way up right now (update via Maintenance --> Manage Extras) that should solve the 4.4.3 specific issues.

Terrific news, thanks James.

Just tested and everything is working perfectly now.

Great! :)

Fixed here too… That was quick, thanks!

Works now for me.

Thanks for fixing the issue.