4.3 only working tethered but supposed to be untethered?

Hi,

 

Hoping someone can shed some light on this nightmare.

Bought an ATV2 that came with 4.2 (iOS 4.3 - 8F191m) which on here: http://forum.firecore.com/topic/3418 says its supposed to be untethered.

 

Spent all day yesterday with just a black screen until i decided to try booting tethered. That actually worked! So does anyone know why im unable to boot untethered?

 

FYI, ive saved by blobs using ifaith from seas0npass Beta. I upgarded to 5.3 to see if that worked, and downgraded successfully…but can still only boot tethered.

 

Any help really appriciated!

Just to mention, I have now tried using  a windows machine to do it, and used the total commander method of dragging the dmg files to ifatih IPSW which is signed. Still no untethered jailbreak working…not sure why this is being so painful when the process is seemingly simple.

Anyone?

Wel, I bought it from you and I can’t get it to work either.  I can jailbreak it in Seas0npass but get no video output.  I can restore it to stock and do get video output.  You reckon it needs a tether program?  Hmm…

I was trying to build a patched IPSW with Sn0wbreeze but it won’t download that IPSW - says it’s invalid.  Odd.

Hmm, you’re right.  Run the tether and it boots…  Now to see if you described it as untethered…