4.1.4 Update Problem - no video output... sort of

I no longer have the GUI the Apple TV, just a black screen. I swapped to a larger external USB hard drive and updated to 4.1.4 and I can’t see anything. Here are the details…

  • Still get video out on start up of ATV (the big opening video piece). Once it gets to the GUI, then nothing but black.
  • Still have sound of me trying to click ‘menu’ and ‘ok’, but it doesn’t go anywhere.
  • If I let it sit long enough I get my screensaver images so it’s not a video out problem.

I’ve tried the following.

  • Restarting multiple times.
  • Reinstalling ATVFlash 4.1.4 as if I were doing it fresh.

Any ideas?

Hallo,
turned on apple tv in order to update atvflash to latest firmware but surprise,
it doens’t…
unplugged, plugged, I can see the intro video, but then, after that, only black screen…
any help?

same here…

i can add that neither Remote HD nor Apple’s remote on iPhone finds the appleTV in the network

alex

Do you know if Remote HD was updated recently? There was a version of Remote HD (available in the early part of June) that exhibited this issue. The issue was cured in the 4.0.3 version which was made available on June 15th.

on AppleTV? I don’t think so… how do you update once installed? and at this stage, do i have a chance of making it work without a factory restore?

thanks
alex

We’ve got little app that can remove Remote HD from the AppleTV automatically…no need for a Factory Restore. Once removed the latest version can be reinstalled through the Maintenance --> Install Extras menu.

PM sent.

whoa! thanks… really appreciate your effort and the urgency to help.

It didn’t work though, screen is as blank as before… I remember, I applied more than aTV update, and the last thing I did was to try to establish a network connection with a computer through NitoTV. I remember seen all the items as “updated” in Manage > plugin settings before that.

Also, I have access to the appleTV through FTP.
Any other ideas?

thanks
alex

have you tried unplugging the USB drive?

Are you using an external drive for iTunes storage?

yes, no usb drive.

so here is what’s happening again, in case we left out some detail:
it starts normally, showing the splash video sequence (= no video problem), then in stead of showing the menu, if shows the black screen. Pressing buttons on the remote will cause a beeping sound. I restarted by pressing the minus button and menu, then run diagnostics, which says that everything is fine.

looking in logs/crashreporter/crashreporter.log shows the last report generated june 5th, so from AppleTV’s point of view, everything is fine…
Any other ideas? delete some preferences maybe?..

thanks
alex

@guardianmax: i was using an external hard drive, but not for itunes storage

Best option is probably to send an email to support: http://www.atvflash.com/contact.php

thanks… I’ll just restore from scratch for now and keep track of what i’m doing

alex

I have the same problem. When doing the update, Nito failed to install, I then menued back, did the other up dates, restarted the finder and the screen went black. Rebooted atv, splash screen ran(no sound)and the screen went black. Don’t have the original patchstick. Ftp still connects to atv.
ATV is now a bricked. Will resetting factory settings(menu+down)reformat the drive and delete all the music and movie files?
Where can I get a version 4.0, the one that used to work?

i’m the original post-er.

i have tried with both external USB drive attached and without. same issues. i never touched any other ‘programs’.

It would appear that it has something to do with the Nitro update. I always save my previous upgrade on a SD card so I just reversed back to the previous version. Tried the upgrade and all went well until the Nitro upgrade when everything went black again. So back to the previous till they fix it.
Art

i have started from scratch, restored AppleTV to factory settings, updated to 3.02, then installed aTV with everything that comes with it, and it works. Sure, it took a while to re-sync with iTunes, but, as I said, it works for me.

alex

Same thing here!
Black Screen after the intro. After 5min my Screensaver kicks in and shows my pictures. I press the MENU-Button and get the black screen again.

I reinstalled the update… reset my aTV… no change at all.

I have no external device on my aTV, or did any change/update to anything… it just didn’t work.

Once again, a great pice of work…!

Now I reset my aTV to the factory settings… making all the network and Sync-Stuff once again and try to forget that I ever installed aTV-Flash…!

I’m outa’here

This may also relate to a Sapphire update. The recent Sapphire update required a database upgrade (auto-update). If this process was interrupted or had issues it could also lead to a black screen.

Try the following.

  1. Connect to AppleTV via FTP (http://wiki.atvflash.com/index.php?title=FTP)
  2. Navigate to Library/Application Support/Sapphire and remove the following two files (if present).

metaData.sapphireDataV2
metaData.sapphireDataV3

Note: Removing these files will require all metadata to be re-imported in Sapphire. You may wish to backup these files(s) to your computer before deleting them from the AppleTV.

Built new patchstick using the link from the received email. Rebooted atv and got the splash screen then black screen and no sound.
Have tried removing saphiremetadate2, as suggested. No joy. ITunes can no longer see the atv, doesn’t show up as a devise, but cyperduck can access ok.