4.01 install endless loop

4.01 on 3.01 results in an endless loop during install. Tried: new USB stick, reformatted USB stick (per instructions where you not only format but zero out), and yet it just keeps rebooting until finally it ends up at the “Restore” menu. I’ve had my ATV since v1.0 and this is the first time I’ve had to do a factory restore. Not what I wanted to prove, but it does take me back to v1.0. Now what do I do to make it work with v3.01? Please help!

William in London

I didn’t get an endless reboot, but just as bad. After the update and the ATV restarts and then after the fancy graphics, it just goes to a blank screen. I think they released the update too soon. Back to the drawing board, boys.

Same here. Updated the AppleTV 3.01 software and it booted fine. Then applied the 4.01 update and am stuck in an endless boot until the diagnostics screen eventually appears. I really don’t want to have to another factory reset. 4.02 on its way maybe??

Same story here with original ATV SW 1.0. Endless loop and then the three options menu with the restore possibility.

Frankly it happened also last time oversion 3.x.x. of ATvFlash; I had to restore to ATV 1.0, upgrade to 2.x and then apply the patchstick again…

It is tough having everytime to resync all the lib. What am I doing wrong ?

It seems a version other than 4.0.1 is being installed. You’ll want to be sure to reformat the flash drive (http://wiki.atvflash.com/index.php?title=Reformat_Flash_Drive) and remove any previous copies of aTV Flash currently on the computer.

Did formatting the usb properly and removing the older ATV Flash files from the PC solve this problem for anyone?

I am reluctant to try 4.0.1 till I know it won’t give me crap.

No, reformatting the USB stick did not help.

I became so frustrated by this, that I restored my AppleTV to factory (1.0) condition, then updated it to 3.0.1 and then tried to flash with the 4.0.1 on a reformatted USB-stick. I am in the same endless loop. The AppleTV goes through the startup video and then restarts and then the Apple logo stays on screen, flashing every now and again.

For the hell of it, I tried the free version of a different commercial patchstick, and it worked. So I think the problem is with aTV flash.


Delete the old folder first. Then download new version. It worked for me. DO NOT simply copy the new version over the old one… something just doesn’t work there as it should.

Thanks, bbh! That was it. It does not work if you copy across the App from inside the folder inside the disk image. You need to copy over the entire folder!

Pity I lost my library along the way :frowning:

I can confirm that deleting the old aATV app on my Mac and reinstalling onto the USB stick has worked but in order to do this I did have to do a factory reset in the end. Attempting to re-install ATV 4.01 over the original botched install didn’t get rid of the endless loop.


I have the very same issue, and at the moment my AppleTV is useless unless I do a factory restore, which I would like to avoid!!

As an important note, it could be noteworthy the fact that I used a AppleTV 1.0 recovery image with Nito Smart Installer to have AFP support and other features. May it be that this is the reason aTV Flash 4.01 didn’t work in my case?

The process for updating the AppleTV to 3.0.1, and installing aTV Flash 4.0.1 is as follows:

  1. Remove all copies of aTV Flash (folders, files, everything) from your computer.
  2. Download a fresh copy here: https://www.atvflash.com/account.php
  3. Format the flash drive to be used as described here: http://wiki.atvflash.com/index.php?title=Reformat_Flash_Drive
  4. Update AppleTV to 3.0.1 through Settings > General menu. (Note: Updates may need to be enabled through the Maintenance > Settings menu.)
  5. Install aTV Flash as before. The current 4.0.1 version will be installed, and will overwrite the outdated version that is on the AppleTV.

If you’re using an external drive as primary iTunes storage you need to add these steps:

  1. Before updating AppleTV to 3.0.1, switch to internal storage through Maintenance > Settings menu (synced media on external drive will not be changed)
  2. Update AppleTV to 3.0.1
  3. Install aTV Flash 4.0.1
  4. Run Smart Installer to enable USB port. http://wiki.atvflash.com/index.php?title=Smart_Installer
  5. Change storage back to external drive. The media that was previously synced to the external drive will be recognized so you won’t need to resync all your media over again.

It is exactly what I did… About a dozen times, actually.

I tried also reinstalling Atv Flash with no enabled options hoping for the AppleTV to get back to default funcitonality but no chances, it keeps rebooting to diagnostic mode.

No chances to get the AppleTV back to working status, I’m going to do the factory restore, which bothers me since to get AFP enabled there’s a lot extra actions to take, mostly not really well documented, but it’s the only way to have it back.

Please, aTV Flash developers, make sure that the next updates also work for user which comes from an 1.0 version (or that have run nitoTV smart installer with the 1.0 boot image trick).

Had the same problem, endless rebooting. I guess the only real solution is to wait for the next release of ATVFlash as even thoose who have got 4.0.1 to work report limited functionality. In the meantime my AppleTv is unuseable unless I reset the unit and resync. I wish I had read the forum posts before I upgraded. A lesson learned! I have to say this is the first problem I have ever encontered with ATVFlash, normally it works like a dream.

One thing I wondered about was maybe Apple have beefed up the security on ATV as they seem to be doing everywhere.

Come on FireCore, we love you but don’t want this mess.

I had the endless boot issue with my appletv… did the following to get afp for network drive working and flash in firefox working.

(This worked for my system not sure about anyone elses, have yet to see a stable release of atvflash yet)

… factory restored to the original 1.0.
… ran the updater for appletv 3.0.1.
… installed the atv flash update to 4.0.1.
… ssh’d into appletv and put the coreaudiokit.framework folder into the documents folder.
… enabled AFP with the following:

  1. On a Mac, locate and open the ‘Terminal’ application inside the Application > Utilities folder.
  2. Enter the following command.
    ssh frontrow@appletv.local
  3. You may receive a security warning. If so, enter ‘yes’.
  4. Enter frontrow as password when prompted.
  5. Enter the following command:
    sudo dd if=/dev/disk0s2 of=/Users/frontrow/Documents/recovery.dmg bs=1m
  6. Enter frontrow as password when prompted. (Note: Once password has been entered, the necessary files will be copied to the Documents folder. This may take several minutes).
  7. Run the Smart Installer

… rebooted and after the 15 sec mount delay I was able to access an external drive connected to my airport extreme base station.
… through the maint screen installed firefox
… through the maint screen installed adobe flash.
… started firefox, went to a flash site and it said the flash plug was missing.
… clicked on the missing plugin icon and let firefox download and install the plug in.
… restarted firefox and flash sites seem to be working fine.

Hi wjohan, I have one question: what is the coreaudiokit.framework step for?

Also, I’m curious to know if you have any clue on how to enable AFP server bonjour broadcasting on the ATV, something I never managed to achieve.

Getting back to the main theme, instead, can anyone from Atv Flash advice the next version, or is factory restore the only way to solve the endless reboot issue?

Too be honest, I put in the coreaudiokit.framework out of habit from having to do countless restores to try to get flash and afp working, it may not be necessary.

For those of you still having trouble, there was a 4.0.2 version released today. This new version has a number of added fail-safes to ensure outdated versions are not being installed on the AppleTV.

Installing this new version should correct any looping issues you may be experiencing.

Anyone update to 4.0.2 yet? I downloaded it and got my flash drive ready, following all of the precautions about deleting prior versions and formatting the flash drive, but I’m a little squeamish about trying the update after the last two caused me to restore and start over again. Surprised to see no reports yet!

The 4.0.2 installer has been changed so that it will not be affected even if a previous version is present in the same location. It also includes a number of fail-safe features that will ensure the correct version is being installed on the AppleTV.