4.0, 4.1, 4.2

I can now jailbreak successfully using TC and an IPSW from a Mac version of SP on

4.0 (8M89) iOS 4.1
4.1 (8C150) iOS 4.2
4.1.1 (8C154) iOS 4.2.1

But every time I connect the network cable, or join a wireless network the screen flcikers on and off - not rapidly, once every ten seconds or so. On for ten seconds, off for ten seconds…

Eventually it goes off altogether…

I have tried in vain to jailbrerak the same ATV2 on

4.2 (8F191M) iOS 4.3

Many times to no avail using the same methodology.

These four versions are the only blobs I have for this particular ATV2 and I am not interested in 5.3 for it.

Does anybody have a fix for this video fault?

I do not have a fix for your issue, but was hoping you could help with mine. I have 2 ATV2 units I bought that were sealed in the box. They are both on the 8m89 4.0 build… I need a jailborken ipsw for 4.0 so I can use total commander to pull the .dmg files.

Do you have one?

Or some other method to JB


I have spent countless hours…

I have managed to install (I think) a jailbokrn image on 4.0 but I should give up if I were you because the only patched image I can make os with Seas0npass and the Seaso0npass patch seems to do something to the network settings and it cuts the video output as soon as you connect an ethernet cable or connect to wireless.  Yours would be the same so now might be the time to give up on it as I have done.

I’m not sure what method you used but after pulling my hair out on a 4.1.1 (8C154) iOS 4.2.1, I used a youtube video, search for GSj_P56jpVg to see it. The only difference is that I used snowbreeze 2.9.14  for windows to create the signed software, and redsnow 0.9.15b3 for mac to put the ATV into Pwned DFU prior to the itunes 11.1.3 for mac restore. It worked like a charm with no video glitches on wifi or ethernet. I tried to be descriptive due to the endless combinations I tried prior and failed. Let me know either way if it works for you guys.