3.4.0 Download - Problems Creating Flash Drive

Using the new download I can’t create a flash drive. I get the can’t find OS boot error. Doing everything the same as before and also using the same flash drive.

using 2GB Astone USB drive same one I have used for all releases prior to 3.4.0 and it partitions the drive fine but hangs on copying files…0% have tried using different update OSBoot images i.e 2Z694-5428-3.dmg it seemed a little more promising as I got some more flashes than usual from the USB stick but still hangs there…also tried gpt destroy/create just in case there where problems with the GUID but nothing, any ideas would be great as I just dropped my Apple TV and naturally the disk started klunking so after jumping on it a few times to get it going I threw the old drive away and used an image I found on piratebay which works a treat as long as your replacement disk is bigger than 60GB so went out and bought a 250 PATA disk and using dd command was able to restore from that nice 2.0.2 image. Also tried another USB key “kingston Datatraveler 2GB” same issue…

You are using the 2.3 DMG right, 2Z694-5573-24.dmg? It was my assumption that you need to use the correct OS image to get the USB stick to work properly. You can Download that image here:

http://mesu.apple.com/data/OS/061-5651.20081119.32VtA/2Z694-5573-24.dmg

The DMG has to be mounted and as well as aTV Flash 3.4. What I do before anything is this:

  1. Open Disk Utility and click on the partition of the USB stick.
  2. Click the Erase tab and click the Erase… button. (name does not matter)
  3. Click on the USB Drive, not the partition. Click the Erase tab and then the Erase… button. (name does not matter)
  4. Close Disk Utility.
  5. Run aTV Flash application with the OS DMG mounted and choose Untitled in the list to choose the USB Drive.

The reason I format the partition first and then the USB Drive second is because I have found problems if I don’t format the partition before formatting the USB Drive. Hope this helps.

Thanks for the help. I guess I didn’t have the OS boot mounted.