3 1st Gen AppleTVs and they all have no Ethernet suddenly. Anyone else?

Ok, Sometime in the last few days, my AppleTVs stopped seeing iTunes.  They also can't be connected to via an FTP client.  They also can't connect to the internet.

 

I have a Time Capsule and all computers and AppleTVs have been assigned DHCP reservations.  The computers all keep the correct IP address, but the ATVs don't.  I even tried manually assigning the correct networking info in the AppleTVs, and that didn't help.

 

Yes, I have VirusBarrier X6, but AppleTVs are trusted, and I even turned VB off, and even shut down the Mac running it whilr trying to use the AppleTV.  Yes, I even rebooted several times after each change.

 

I downloaded and reinstalled the latest atvFlash to no avail.  All 3 AppleTVs are running the latest Apple 3.0.2 software.

 

I don't get it.  I don't think it is the TimeCapsule because only the three AppleTVs are having issues.  I don't think it's VirusBarrier because it's been turned off.  I guess it could be the iTunes 10.2.1 update, but every post I read is fixed with a reboot.

 

I'm running the latest Snow Leopard.  Nothing on the wired network has changed.  I can't test WIFI because I removed the card to install the CrystalHD chips in all three AppleTVs.

 

I'm really lost.  Any ideas?  Please....  and thanks....

 

Jim

The problem was the power supply on a switch that was in the mix.  Once the power supply was replaced, all worked as normal.  The odd thing is though that all devices went through that switch, and yet only the AppleTVs had major issues due to it.

 

Thanks for reading.