2TB External drive

Hi,

I have recently bought a 2TB SATA drive and have connected this to my ATV using a CnM Docking station.

Connected it to my mac and it worked a treat, so kind-of expected it to work first time on my ATV, and it sort-of has, but hasn’t.

I SSH’d to the drive and checked what drives are attached:

-bash-2.05b$ diskutil list
/dev/disk0
   #:                   type name               size      identifier
   0:  GUID_partition_scheme                    *149.1 GB disk0
   1:                    EFI                    34.0 MB   disk0s1
   2:         Apple_Recovery                    400.0 MB  disk0s2
   3:              Apple_HFS OSBoot             900.0 MB  disk0s3
   4:              Apple_HFS Media              147.7 GB  disk0s4
/dev/disk1
   #:                   type name               size      identifier
   0: FDisk_partition_scheme                    *1.8 TB   disk1
   1:              Apple_HFS 2TB                1.8 TB    disk1s1

But when I check what volumes are mounted:

-bash-2.05b$ ls /Volumes/
OSBoot

I can see in the ~/Movies directory that it has also tried to sym-link the drive, but this does not work:

-bash-2.05b$ ls ~/Movies
2TB
Recovery
The Matrix - Revolution
-bash-2.05b$ cd ~/Movies/2TB 
-bash: cd: /Users/frontrow/Movies/2TB: No such file or directory

So, I wanted to know if anyone could help, I’ve tried rebooting the ATV with the drive attached, I have formatted the drive using DiskUtil on my Mac. When I perform a ‘diskutil list’, I can head the drive spin-up, so its definitely recognised, but not mounting as I’d expect.

Cheers for your help in advance!!

@dualcyclone

You may try changing the partition scheme to GUID in Disk Utility.

Disk Utility --> Select Drive --> Partition tab --> Options