1Gen black screen after booting

I have a 1 st gen apple tv which up until now has been working fine. i turned it on the other day, and after the fancy start up, with the floating screens, there is no menu at all?

The screen saver comes up and you can hear the beep when you press a button, but nothing else, just a blank screen, so i cant seem to do a reset?

Can anyone help?

Well, I have sort of the same problem!

I installed the latest version aTV Flash 4.3 today and it said it did a great job in installing aTV Flash. I unhook the USB drive and restarted the atv. I briefly see the apple logo and then my screen turns black (blue actually). I do not get the start-up screen nor do i hear any sound. The tv-set tries to decode the signal, but after a minute or so, it says, no signal. And the screen stays black.

Hitting the menu button will at some occasion show a reset of the screen and a faint beep - but nothing else. It’s like neilc’ problem.

Please firecore team, any suggestions how to fix this problem?

 

My Apple TV is bricked as well, thanx to Boxee.  I’ve tried SSH into the system to delete the Boxee install, no help.  Can someone please post a fix?

I suspect some of you have the same issue I did and that is after the recent update this happened.

 

Firecore support here has given me 2 replies since June 1 when this first happened . In the first one they said to simply navigate to the menus and reformat, although I was sure that I indicated clearly I had a black screen!

 

The second reply which I received several hours ago many days later, and after insisting I wanted to try to save my config, was equally lame sending me to awkawardtv site. IF I do that then why bother with a commercial product? At that same site you can do it all without paying Firecore for what they do not deserve, as I already knew…

 

My partial solution…

make a back up of /etc/rc.local

in the file then open with nano or vi or a text editor and delete all entries.

Reboot ATV

 

you will now at least have your menus, and can initiate a factory reset.

 

For some reason the kexts seem to no longer load after the update. I made firecore aware of this a week ago.

 

Firecore has locked me out of further updates and the old program that I got with my used ATV , no longer works. I will probably not use the firecore product at all this time around. 3 installs that have gone bad in a month is too many.

 

Tonight I did a factory restore and deleted all of my XAMPP installation and all of the extras. Firecore has not worked for me, after three installs, and I do not recommend it to anyone. It is HIGHLY UNSTABLE, although It is a sure quick unlock and installation but when things go wrong they just tell you to restore (even when you can not) and dont even bother reading about your problem. They have ZERO concern for what you will lose along the way. This seems to imply that ATV flash is a hack, based on open source solutions that they want to charge you money for. I suppose Apple customers are used to paying (too much) for everything anyway.

 

Good luck to you and I hope you find a solution as I do not believe firecore will.

 

Next time Build a HTPC and install from XBMC live. The simplicity if that installation beats the heck out of an unsupported commerial product that seems so unstable.XBMC Live will also run off a 4 GIG memory stick with no issues.

 

I just wish that someone would make an XBMCLive for ATV , then I could delete ATV all together.

 

There may be another cause of this.

 

If you have any USB devices connected, disconnect them then reboot. I would be interested in knowing the results

I’ve disconnected the USB an rebooted. Still a black screen after start up. I do get the screensaver up and the clicking noise when I press a button, but nothing else.
Surly someone can sort this out?
Otherwise I’ll invest my money in a different streamer.

I found a fix.  It’s a bit of a hassle, but it worked for me…

 

  • I used the Terminal on the Mac to SSH into the Apple TV
  • Once in, I made the OS boot partition unbootable by renaming the Mach.sym and mach.kernal.prelink
  • This forces the Apple TV into recovery mode and brings up the screen to do a factory restore
  • From there, just do the restore, get back to the latest version of the firmware
  • Then you can re-install ATV Flash and stay away from Boxee until this can be resolved

.

Instructions on how to do this can be found here…

http://scottforbes.net/2010/02/27/appletv-how-to-force-a-factory-restore-via-ssh/

.

When you are in the terminal, you may get a read-only error.  If so, type the following…   sudo mount -uw

Then continue with the instructions from the link above and you should be good to go.

 

Any questions, let me know.

When I try to change the filename I get his message:

mv: rename /mach.sym to /bad.mach.sym: No such file or directory

Even after running the mount command.

Any ideas?

Jeff

Not sure you used the correct command.  I used this…

sudo mv /mach.sym /bad.mach.sym

If you did enter the mount command, you could try doing this using FTP instead of the terminal



Yup that’s exactly how I entered it:

 

-bash-2.05b$ sudo mv /mach.sym /bad.mach.sym

Password:

mv: rename /mach.sym to /bad.mach.sym: No such file or directory

I'm not familiar with how to use FTP w/ the Apple TV
Get the same error w/ or w/o the mount command

Here are the instructions on how to FTP to Apple TV…

 

Ok maybe I’m doing something wrong here…

Network Error: Connection failed
Connection refused

Hmm.  Try following these instructions from Apple to force an Apple TV restore…

Here’s how to restart an Apple TV:

  1. Pick up the remote.
  2. Point it at the Apple TV
  3. Press and hold both Menu and down (-) on the Apple Remote for 6 seconds or until the status light blinks amber.
  4. The Apple TV should Reset itself and show you a screen where you can select one of the following:RestartRun Diagnostics or Factory Restore. Select Factory Restore.

Yeah I recently found one of my long-lost Apple TV remotes and tried the above but the battery appears dead - I’ll have to get a new one and try again. Thanks for all your help.

 

Jeff

 

 

Your a winner!!!

 

OMG I have spent all day trying all this shit and all it took was 2 buttons on the remote. OK so far I believe the team at ATVflash owe me 50-60 hours plus stress pay for the 100 plus issues I have had to deal with. Is ATVflash coming out of Beta soon?Lol. ATVflash is a massive FAIL and I wish It never hit the market. But Im the idiot still “hacking” a hack… :frowning:

I sadly have the same problem. Screen stays black after installing the latest version.

 

Why is there no solution to this problem. Very very poor!

I haven’t installed or updated anything on my box in a long time. It was working fine until this evening. I restarted it due to overheating and since then it will boot as normal, but just gives a blank screen - after the animation. Really really annoying.

I can SSH into it, but I’ve no idea what I’m meant to be doing.

:frowning: