12 Hours of Installation Hell in Windows -- Then Salvation! Sort of.

UPDATED 3/26/11

Ok. TV Flash (black) Beta4 arrived and so I decided to give it another go.  I went back and re-downloaded Seas0nPass and then the TV Flash (black) Beta 4.

Originally, I had tried to perform installs of the previous Beta using both an XP Pro machine and a Windows 7 Ultimate box, both without success. This time I started with my aging DELL D400, an XP Pro notebook with SP3 and .NET 1 through 4 installed. I re-ran the Seas0nPass jailbreak and TV Flash install as per the online instructions and SUCCESS! Everything installed without a hitch exactly as advertised. Sort of.

Once I get everything installed and setup I discovered that I could not cannot allow my Apple TV 2 to lose power.  After doing the install in my office, I then put the ATV into sleep mode (thinking that would be the best mode for it to be in when I unplugged it) and transferred it back to my home theater.  I then re-attached HDMI, optical, and power where the ATV prompting began booting and hanged with the frozen Apple logo of death.  No combination of power first vs. HDMI first solved the issue.

The only way I could revive it was to bring the notebook to the ATV and perform another tethered boot.  Not good.  For those without a UPS attached to their ATV's any brief power outage will force the user to perform another tethered boot as I have.  I don't know if this is a problem with the Apple hardware (seems unlikely) or a glitch with TV Flash (black) Beta4 but either way, I plan to add a UPS to the mix.

Hopefully the next release will resolve the tethered boot issue once and for all.

 

ORIGINAL POST

Spent all day yesterday attempting to install aTV Flash(black) on my new ATV2 -- total waste of time.  12 Hours of cycling through jailbreaking with Seas0nPass, installing aTV Flash(b), having that all fail, resetting to factory defaults via iTunes and then starting over again.  In the end all aTV Flash would ever do is display the Apple logo for a few seconds and then the TVs would say they lost the HDMI signal (yes, I tried on 2 different HDTVs). Grrrrrrr.

Spent about 4 hours [unsuccessfully] attempting installs via my old XP Pro SP3 notebook (my longtime dedicated defacto iTunes server) then spent another 8 hours on one of my Windows 7 64-bit Ultimate boxes. Tried doing tethered and untethered boots. Nothing. And while the Windows 7 installations never gave an error message (XP was riddled with them) in the end the installations never took. Complete failure.

Not that it matters now, but the instructions on FireCore are pretty bad.  They're obviously favoring Macs with missing Windows screenshots and incomplete explanations that could be far more explicit.  The differences between the two are significant enough that Windows installations really do warrant their own section.

It would be nice too if we could simply download the latest AppleTV2,1_4.3_8F191m_SP_Restore.ipsw file(s) directly rather than rely on Seas0nPass to do this in the background. The risk of corruption during download and decryption is just too great otherwise and are likely what is causing the installs to fail for so many users.

As an aside, when iTunes loads the new .ipsw file that Seas0nPass generates it returns a very unsettling message, stating that you are about to downgrade your AppleTV to version 4.2 – very unsettling especially since there is a “4.3” in the filename.