[#100593] Infuse not playing the mkv default audio and subtitle track

Hi,

I noticed a bug with mkv files. Infuse doesn’t play the audio and subtitle track set as default in the mkv even when the track has the “force track flag”
I have the last tvOS and Infuse update installed.

Edit (more details):
In my case the mkv include:

  1. Video (Default track)
  2. JAP Audio (Determine automatically)
  3. JAP Sub (Determine automatically)
  4. FR Audio (Default and Forced track)
  5. FR Sub (Default and Forced track)
  6. Chapters(Default track)

And by default Infuse play Japanese track, but when I set the right track and stop the episode from playing and come back Infuse play the mkv as it supposed to be.

Sincerely

This also applies to all Norwegian content, whether it’s audio, subtitles or metadata. I hope the bug gets fixed soon, as Infuse without the default settings is not the same.

Is French selected as the default audio language in Infuse settings?

It’s set on Auto. So it supposed to play the track that has the default flag in the mkv, just like VLC does and like Infuse was doing before. But again strange thing when I set the right track and stop the episode from playing and come back Infuse play the mkv as it supposed to be.

I am guessing that if you set it to French it will work as you intend.
(I am French too btw)

My understanding is that with audio language settings to auto, Infuse will try to use the system (Apple TV in that case)'s language, but I might be wrong.
I have my Apple TV’s language set to English and Infuse’s audio and subtitle languages set to Auto and Infuse seems to always pick an English audio track when one is available. Same with my iPhone, for which system language is French, and Infuse audio and subtitle languages are English.

Infuse remembers which audio and subtitle tracks you previously selected, which explains why it gets it right the second time.

Regarding forced subtitle tracks, they are here to supplement the audio tracks for elements which would not be translated, such as writings or alien language.
In the case of your media, if you select the French audio track, the forced french subtitle track will be automatically activated.

Oh ok that’s why!

But in the past versions Infuse was able to play the audio and subtitle tracks set as default or I mis-remember?

I can’t tell but I only remember Infuse behaving the way it does today.

?So it means I will have to manually change the audio track and subtitle track. Hope an update will patch this behavior

That would probably be worth a post in the suggestions forum https://firecore.com/forum/suggestions

Done: Let Infuse play the default language of mkv files

The upcoming 5.7.3 version of Infuse will correctly honor the default flag for audio and subtile tracks. :slight_smile:

Including Norwegian?

Yes, should be working in 5.7.3. :slight_smile:

Infuse❤️?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.