10.5 version of CoreAudioKit.framework = Quicktime trouble?

I loaded the 10.5 version of /System/Library/Frameworks/CoreAudioKit.framework instead of the Tiger version. Flash does not work as a result. Will this also make Quicktime not work too? It says that it is installed, but I get a Quicktime ‘?’ or the system crashes and reboots when I try to watch Quicktime movies.

Also, when I place the correct version of /System/Library/Frameworks/CoreAudioKit.framework in the documents file do I have to do anything else because the 10.5 version was there previously or will the Tiger file just overwrite the incorrect file?

So far aTV Flash has been a frustrating experience, but I’m not giving up just yet…

Thanks for the help!

Yes, unfortunately not having the correct CoreAudioKit.framework file installed will result in the problems you are experiencing.

If you can locate the correct CoreAudioKit.framework file, you would go through the same steps to install.

  1. Copy to Documents folder.
  2. Select Flash Installed (previously Install Adobe Flash) from Maintenance menu.

This will remove the installed CoreAudioKit.framework, and replace it with the one currently located inside the Documents folder.

Well, I did all that and I am still not able to view Flash Video or Quicktime video. WHat now?

Where did you get the CoreAudioKit.framework from? It must be an Intel Tiger version.

Hi -

I did have the incorrect version of CoreAudioKit, but I got the correct one finally from a very kind person. Flash is now installed, but Quicktime still does no work. I clicked on “Quicktime Installed” so it would install again after I got the correct version of CoreAudioKit, but still nothing. Also, the Flash video that play in CS are choppy. Is there any way to fix that. When that is taken care of and I am able to view Quicktime is working I will be a happy camper.

How long do you let the AppleTV sit there before restarting it when trying to install QuickTime? I had to let my AppleTV sit there for about 5-10 minutes before I got a message it was installed.

It took a few minutes before the “Installed” message came up, but it did come up before I restarted. Now Quicktime movies just crash the system :frowning:

same here, the Quicktime install takes 5-10min.

perhaps installing the 10.5 coreaudiokit also borked Quicktime beyond what gets replaced with a Quicktime reinstall, & you’ll need to factory restore & start again?

i’ve tried installing a 10.4.10 coreaudiokit, but Couchsurfer crashes every time its hits a Flash page. is 10.4.9 the ONLY version that works? i only have 10.4.10 discs :frowning:

The CoreAudioKit I have installed is from a 10.4.10 Tiger disk, and works perfectly (See my post in thread ATV 2.1 CouchSurfer: No Quicktime Movies).

I did exactly the things to do:
Update latest apple tv version
Install flash apple tv
copy CoreAudioKit.framework (tiger intel version)in the documents directory from apple tv
mantenance menu click on install Adobe flash, it say’s install flash correct
reboot the apple tv but flash does not works.
What can i do after 3 days frustration?
Who can help me??? :oops:

I use Leopard (version 10.5.6) and don’t know where to get 10.4.10 version of CoreAudioKit Framework. Is it available somewhere I can download from?


Attached is CoreAudioKit.framework.zip for version 10.4.10, in case someone is looking for it. It works like a charm on my AppleTV. Flash rocks!

EDIT by Madcran: The file is copyrighted and can not be posted for distribution. Sorry. :frowning:

Thanks Madcran for correction. It was an honest mistake.

Could you send me the CoreAudioKit.framework.zip file? Thanks.

me too please. I threw out my tiger discs a few months ago…

I’d really appreciate it if you could also email this file to me… many thanks.

Is there any way u can email this to me as well? I only have 10.4.9 install disc and have already upgraded to 10.5 :frowning:

Don’t know if i’m allowed to do this but, you can obtain the file from this location:

[EDIT - Please no torrent links]

This is untested by myself but looks good.

would someone please send me a copy at jlarsen5@gmail.com?


This installation procedure is similar for a pc correct? I use FileZilla to drop the file into the applications folder then install flash from Maintenance correct?

Can anyone also let me know a reliable torrent or send me the file also?

Many thanks